[ar] [ca] [cpf] [de] [en] [es] [fr] [it]

Ce forum d’entraide est recommandé pour les utilisateurs et utilisatrices occasionnels de SPIP (Système de publication pour l’Internet). Avant de poser une question, faites une recherche sur ce site, consultez les liens utiles. Si vous ne trouvez pas de réponse, postez votre message dans la rubrique appropriée, avec un titre explicite.

Sujets : 24073 Sujets résolus :  39 %

74 visiteurs en ce moment


Oups. Une erreur inattendue Résolu

par chris - 9 mars 20:54 - Réponse(s) : 3

J’ai un spip 3.1.4 chez Hostpapa et depuis les dernières mises-à-jours quand je met un code youtube comme ceci dans le champ texte d’un article.

  1. <iframe width="560" height="315" src="https://www.youtube.com/embed/GVac3D7Sl3U" frameborder="0" allowfullscreen></iframe>

J’ai une alerte

« Oups. Une erreur inattendue a empêché de soumettre le formulaire. Vous pouvez essayer à nouveau. »

et l’article ne s’enregistre pas.

J’ai essayé de désactiver tout les plugins, vider le cache, ça fait pareil.


  • Je ne reproduis pas le bug... En local, as tu aussi le bug ?

    Peux tu nous donner la version de PHP et de ton serveur svp.


  • < #2 > Oups. Une erreur inattendue  ˆ
    par chris - 10 mars 11:15

    PHP Version 5.6.28

    J’ai d’autres sites à jour avec la meme version de php chez un autre hébergeur qui n’ont pas ce problème.

    J’ai installé un second spip clean neuf sans plugins sur ce même hébergement, j’ai pas le oups mais ça mouline dans le vide à l’enregistrement.

    Si je vais modifier mon article dans phpmyadmin, que je colle mon code youtube dans la base directement. Je peux enregistrer et je le retrouve ensuite dans spip.

    J’ai pas testé sur un local genre MAMP, mais si ça marche chez un autre hébergeur, ça doit plutot venir de mon hebergement non.

    Ici il y a un type qui râle sur Hostpapa et son firewall qui coupe les ressources exterieures.
    http://www.top10hebergeurs.com/avis/hebergement-france/HostPapa-22.php?page=35

    Je leur ai posé la question, j’ai pas de réponses...

    J’aimerais trouver quelqu’un qui a un site chez Hostpapa avec un spip à jour et savoir si un insert youtube lui pose aussi les mêmes problèmes.

    Si ça peut aider....
    http://www.gallotta-danse.com
    http://www.gallotta-danse.com/phpinfo.php


  • < #3 Oups. Une erreur inattendue  ˆ
    par chris - 13 mars 06:52

    J’ai finalement eu la réponse de Hostpapa

    Thank you for your patience. What happened here is that the iframe was causing a modsecurity rule on the server to activate. As iframes injecttion are common for malware. I’ve disabled the rules hit for the domain, so even on your actual site it won’t happen

    Mais c’est un peu dingue qu’un hébergement ne permette pas par défaut d’inclure des Youtube sur son site pour raison de sécurité, et que ce paramètre ne soit pas désactivable depuis une console d’admin et demande l’intervention du support....




Répondre à la question

« Oups. Une erreur inattendue  »

Mots-clés

Vous pouvez étiqueter cette page de forum avec les mots-clés qui vous semblent les plus appropriés ; ils permettront aux prochains visiteurs du site de mieux se repérer :


Installation, mise à jour

Utilisation de l’espace privé

Administration, gestion, configuration du site

Créer ses squelettes

Qui êtes-vous ?

  • Impossible d'éditer un auteur (site existant importé)

    par kikinovak
    25 juin 12:48

    Résolu - Réponse(s) : 3

    J’ai fini par trouver. En fait il s’agit d’un SPIP considérablement modifié, avec pas mal de plugins tiers, dont un qui posait problème. Ça venait d’un bug dans une version personnalisée du fichier (...)

  • Site inaccessible selon les browsers

    par abel
    23 juin 08:01

    Réponse(s) : 2

    Merci pour ta réponse :) Donc les navigateurs auraient une tolérance différentes selon le temps de chargement de la page ? Parce-que ceux qui ne chargent pas le site ne le font jamais, et sur (...)

  • Fonction "recherche d'adresse" de GIS cassée sur sites récents

    par b_b
    16 juin 11:44

    Résolu - Réponse(s) : 3

    Pour info, la version 4.43.6 de GIS devrait corriger ce problème, cf : https://zone.spip.org/trac/spip-zone/changeset/104884 ++

  • numérotation incohérente ?

    16 juin 09:49

    Résolu - Réponse(s) : 1

    Réponse trouvée si ça intéresse quelqu’un : la base de donnée Mysql du fournisseur d’accès numérote les enregistrements par pas de 3... Obligation donc de réécrire les squelettes en les compliquant un (...)

  • Site multilingue déféctueux

    par Didine
    16 juin 06:46

    Réponse(s) : 1

    Bonjour, Par défaut la page traduite créée est en français, il faut donc vérifier que ta page dans le secteur anglais a bien comme langue l’anglais. Sinon pour afficher la bonne page selon la langue (...)

  • Erreur système (errno 130)

    par erational
    5 juin 08:17

    Réponse(s) : 3

    Peut-on connaitre le nom de l’hébergeur ? Si tu as des bases en données en plus ? Si oui, tu peux essayer de cloner ta base et la brancher sur la nouvelle base ? Tiens nous au (...)

  • installation de themes

    30 mai 18:36

    Réponse(s) : 9

    La 1ere question du #6 est sans réponse. Celà pourrait aider à résoudre ton prob.

  • bug après avoir essayé de vider le cache

    par arcadiamo
    26 mai 18:34

    Réponse(s) : 4

    Merci , mais j’essayerai quand j’aurais résolu l’accès au serveur FTP car là je n’ai accès a rien du tout.

  • Une erreur technique a empêché l'enregistrement correct du champ 'date_lim'

    par laetitia
    24 mai 17:57

    Réponse(s) : 2

    en continuant mes recherches, je suis tombée sur un post intéressant dans lequel on parle de l’« affichage des calendriers des dates comme dans l’interface privée et à faire en sorte que le (...)

  • Probleme d'encodage en base de données

    par erational
    25 mai 12:30

    Réponse(s) : 2

    le plugin grenier peut parfois aider : https://contrib.spip.net/Convertir-un-site-SPIP-3-en-utf-8-avec-le-plugin

  • Messages : 29607
  • 8700 34 %
  • Poser une nouvelle question