[ar] [ca] [cpf] [de] [en] [es] [fr] [it]

Ce forum d’entraide est recommandé pour les utilisateurs et utilisatrices occasionnels de SPIP (Système de publication pour l’Internet). Avant de poser une question, faites une recherche sur ce site, consultez les liens utiles. Si vous ne trouvez pas de réponse, postez votre message dans la rubrique appropriée, avec un titre explicite.

Sujets : 24076 Sujets résolus :  39 %

42 visiteurs en ce moment


Accueil > Forums de discussion >  Utilisation de l’espace privé > Rotation illustration dans les articles

Rotation illustration dans les articles Résolu

par staff - 30 janvier 15:25 - Réponse(s) : 4

Bonjour,

Voila ma configuration : Debian 8, Spip 3.1.3, php5
J’ai installé php5-gd et php5-imagick en plus comme paquet.

Au niveau de l’espace privé dans "/édition/article" au niveau de la zone illustration (après ajout d’un document).
Quand j’essaie de faire une rotation sur une illustration (modification et utilisation de la flèche). j’obtiens le message suivant (Oups. Une erreur inattendue a empêché de soumettre le formulaire. Vous pouvez essayer à nouveau).

Quand je vais sur le serveur voir les logs, je n’ai aucune trace de l’erreur.

J’ai vérifié le fichier "plugins-dist/filtres_images/filtres/images_transforme.php" et il semble avoir la bonne instruction (if (method_exists(’Imagick’, ’rotateImage’)) )

Pourriez-vous me dire qu’elle est la marche à suivre pour faire fonctionner la modification de l’image ?

Merci d’avance


  • Salut,

    GD est activé dans la configuration avancé du site ?

    ecrire/ ?exec=configurer_avancees


  • Bonjour

    Merci de ton aide.

    J’alterne entre GD 1, 2 et Imagick, mais ça ne change rien.
    J’ai bien les miniatures quand je choisi GD ou imagick dans la génération de vignette.

    J’ai lu sur un poste qu’il fallait peut être redémarrer le serveur (physiquement) pour que ça fonctionne. Je vais faire le test entre 12h et 14h.

    cordialement


  • Je sais pas quel est votre serveur web ?

    Mais en général il suffit de redemarrer le service http:

    1. service apache2 restart

    penser à vider le cache de spip egalement dans -> maintenance -> gestion du cache.

    le mieux c’est utiliser GD2 dans la config de spip.


  • Merci pour l’info.

    Je l’ai fait mais ça n’a rien changé.

    Je viens de vider le cache et de redémarrer le serveur.

    La ça fonctionne...

    Donc j’ai mis GD2 dans la configuration, j’ai vidé le cache, j’ai redémarrer le serveur (reboot) et la rotation fonctionne.

    Merci pour l’aide, c’est sympa d’avoir pris le temps de te pencher sur mon problème.




Répondre à la question

« Rotation illustration dans les articles »

Mots-clés

Vous pouvez étiqueter cette page de forum avec les mots-clés qui vous semblent les plus appropriés ; ils permettront aux prochains visiteurs du site de mieux se repérer :


Installation, mise à jour

Utilisation de l’espace privé

Administration, gestion, configuration du site

Créer ses squelettes

Qui êtes-vous ?

  • Comment créer un portfolio de vidéos avec affichage mediabox ?

    par Cyriaque
    13:24

    Résolu - Réponse(s) : 6

    Merci placido pour ton aide ! La deuxième version du modèle album.html + le plugin Albums fonctionne correctement. J’ai juste retiré dans le script la ligne 180 : rel:'galerieauto', car sinon je ne (...)

  • Mes plugins ont disparu - SPIP V3.0.16

    par Raphaël
    13:22

    Pas de réponse

    Bonjour, Je rencontre un problème extrêmement similaire à celui signalé sur ce post : je n’ai plus accès à liste de mes plugins depuis le backoffice qui sont pourtant présents et effectivement actifs. (...)

  • Le menu déroulant des rubriques en sous rubriques a disparu

    par erational
    28 mai 18:12

    Réponse(s) : 4

    oh la la ton SPIP est très ancien SPIP 1.9.2b il faut absolument que quelqu’un le mette à jour. tu risques un piratage à tout moment. ps. PHP est langage de programmation. il permet de créer des (...)

  • squellette maparaam sous spip2.1.8

    par nora
    24 mai 20:51

    Réponse(s) : 27

    Bonsoir, je suis sous spip 2.1.8, avec un compte administrateur mais j’arrive pas à créer des comptes (auteurs) pour des utilisateur de notre site web sous spip. je peux modifier un compte qui (...)

  • Bug : identité site, adresse URL

    par b_b
    16 mai 20:12

    Réponse(s) : 5

    Comme tu peux le voir, les squelettes par défaut ajoutent ce slash final, tu n’as donc qu’à adapter tes squelettes persos pour en faire de même : https://zone.spip.org/trac/spip-zone/browser/_core_/plugin

  • Appel de logo dans l'édition d'un article sur l'espace privé

    par Lucie
    9 mai 18:16

    Résolu - Réponse(s) : 2

    En effet ! Merci ! Je ne m’étais pas penchée du côté des pulgins mais plutôt vers les modèles SPIP. Cela fonctionne parfaitement avec ce plugin. Je mets donc en résolu (...)

  • Copier un article

    5 mai 16:52

    Résolu - Réponse(s) : 4

    Pour donner une solution à ce problèm, on peut noter la présence de https://contrib.spip.net/Plugin-Duplicator

  • HTTP 302

    par Ajel
    30 avril 00:32

    Résolu - Réponse(s) : 52

    Pour moi j’ai eu le même message en installant spip 3.1, à l’étape 4. J’ai juste renommé htaccess.txt par .htaccess est le problème est résolu. Voilà si ça peut (...)

  • bug suite à restriction d'accès sur 'gestions des plugins'

    par Christophe Seguinot
    28 avril 16:19

    Pas de réponse

    Bonjour J’ai tenté de restreindre les accès des administrateurs à la configuration/’gestion des plugins’ de mon site. Soit en surchargeant la fonction autoriser_configurer_dist Soit en utilisant le (...)

  • erreur lors de l'ajout d'image

    28 avril 09:06

    Réponse(s) : 4

    Et mettre à php 7

  • Messages : 9550
  • 2406 39 %
  • Poser une nouvelle question