[ar] [ca] [cpf] [de] [en] [es] [fr] [it]

Ce forum d’entraide est recommandé pour les utilisateurs et utilisatrices occasionnels de SPIP (Système de publication pour l’Internet). Avant de poser une question, faites une recherche sur ce site, consultez les liens utiles. Si vous ne trouvez pas de réponse, postez votre message dans la rubrique appropriée, avec un titre explicite.

Sujets : 24108 Sujets résolus :  39 %

60 visiteurs en ce moment


Accueil > Forums de discussion >  Création de squelettes > Balise meta de la page d'accueil

Balise meta de la page d'accueil Résolu

par vince - 7 novembre 2011 12:50 - Réponse(s) : 18

Bonjour tous
je reprends un site sous Spip (v2.1.2)... et j’ai du mal...
j’essaie de modifier le

de l’accueil car je n’ai pas de balise pour la description du site (juste Content-type et generator). (http://www.tragopan-asie.com/) Impossible jusqu’ici. J’ai essayé de changer sommaire.html, même head.html mais aucune modification ne fonctionne. Ce qui m’étonne c’est qu’en renommant sur mon ftp les dossiers squelettes et squelettes-dist, le site s’affiche toujours sans modifications (même en vidant le cache navigateur) ??? Où Spip prend-il alors les infos de structure ??? help...

  • Deux choses à vérifier, la première est d’être sur le bon ftp.
    Rajouter un fichier à la racine http du site avec un nom unique et de l’appeler.

    Ensuite vérifier qu’un plugin ne gère pas l’affichage (genre SpipClear) ou qu’un thème ne soit en place sur un répertoire autre que "squelettes".


  • < #2 > Balise meta de la page d'accueil ˆ
    par vince - 7 novembre 2011 16:18

    Alors je suis bien sur le bon ftp (j’avais fini par en douter aussi :-) )

    j’ai effectivement un thème qui se trouve dans un dossier "themes" à la racine (donc hors squelettes et qui ne contient que 2 .html et qqs autres fichiers). Le problème vient de là ?
    Comment y remédier ? Déplacer le dossier themes ?
    Merci Alexandre pour ta réponse rapide !


  • Un thème est un plugin, donc dans la liste des plugins tu as peut-être un thème.
    Auquel cas tu sauras où intervenir.

    N’utilisant pas personnellement de thèmes je ne pourrais pas plus t’aider.


  • < #4 > Balise meta de la page d'accueil ˆ
    par anic - 8 novembre 2011 09:13

    Bonjour,
    nomdusite.com/spip.php?page=sommaire&var_mode=inclure liste les fichiers inclus et leurs chemins.
    Le système de thème repose sur le plugin zpip dont les fichiers sont éventuellement surchargés dans /squelettes


  • < #5 > Balise meta de la page d'accueil ˆ
    par Emmanuel - 8 novembre 2011 10:44

    Bon, le plugin/squelette semble fonctionner (voir http://www.tragopan-asie.com/phototheque-gallery/)
    Il n’y a un problème que pour le sommaire.html qui n’a pas été écrasé.

    Donc il faut reprendre les instructions du plugin :

    Afin de faire fonctionner le plugin avec Zpip, copier tous les dossiers contenus dans ce fichier (zpip) et coller les dans /squelettes.

    et déziper dans le répertoire /squelettes le fichier sommaire.html


  • < #6 > Balise meta de la page d'accueil ˆ
    par vince - 8 novembre 2011 12:21

    merci pour prendre le temps de me répondre.

    euh j’ai essayé de lister les fichiers inclus comme suggéré par anic ; mais maintenant l’accueil du site a gardé la mise en forme de ce test (sans les lignes surlignées, squelettes/sommaire.html, squelettes-dist/inc-head.html, squelettes-dist/inc-entete.html...)
    alors que sur les autres pages la mise en forme est conservée...

    Je débarque dans spip (4 jours "d’ancienneté") donc beaucoup de notions à digérer et une structuration imbriquée (theme, plugin, squelette, -dist...) qui ne me facilite pas la tâche.

    je vais lire en détail les infos sur zpip... (re-déziper sommaire.html dans le répertoire squelettes n’a pas résolu le problème...)

    toute future aide est la bienvenue :)


  • < #7 > Balise meta de la page d'accueil ˆ
    par anic - 8 novembre 2011 12:29

    re-bonjour,

    Pour retrouver la page normale il suffit d’enlever ’var_mode=inclure’ de l’adresse de la page. Cette fonction ne peut pas être activé par les visiteurs du site.


  • < #8 > Balise meta de la page d'accueil ˆ
    par vince - 8 novembre 2011 16:30

    j’ai l’affichage du test même en appelant juste "http://www.tragopan-asie.com/"... (je suis le seul ou bien ?). Les autres url sont normales.

    problème de cache qq part ? (bien que j’ai vidé le cache sous l’espace privé, sans résultat)

    je ne comprends plus grand chose... (pour info, je n’ai de problème qu’avec ce site...)


  • < #9 > Balise meta de la page d'accueil ˆ
    par Emmanuel - 8 novembre 2011 16:45

    Je me permets d’insister dans le répertoire http://www.tragopan-asie.com/squelettes/, le fichier sommaire.html est le fichier standard de SPIP (auquel il manque le CSS correspondant, ce qui explique la mise en page bizarre)

    Il faut prendre le fichier sommaire.html qui se trouve dans le répertoire http://www.tragopan-asie.com/plugins/zpip/ et le copier dans le répertoire http://www.tragopan-asie.com/squelettes/

    Les autres fichiers .html squelettes ont été transférés pas celui-là


  • < #10 > Balise meta de la page d'accueil ˆ
    par vince - 8 novembre 2011 16:58

    si je clique sur "sommaire" en bas de page de mon thème j’ai l’affichage de sommaire.html et en bas de ce document :

    [an error occurred while processing this directive]
    [an error occurred while processing this directive] [(#REM) Menu de navigation laterale ]
    [(#REM) Menu de navigation par rubriques ] #FORMULAIRE_RECHERCHE
    [an error occurred while processing this directive] [(#REM) Menu de navigation laterale ]
    [(#REM) Inscription au site ] #FORMULAIRE_INSCRIPTION
    [an error occurred while processing this directive] [(#REM) Pied de page ]
    [an error occurred while processing this directive]

    est-ce que ça parle à quelqu’un ? (ça explique pourquoi je n’ai plus la structure normale de la page mais pas comment je le répare :-(
    en googlant ça peut être lié à un # mal placé...

    le code de /squelettes/sommaire.html pour cette partie est :

    1. <div id="navigation">
    2.  
    3. [(#REM) Menu de navigation par rubriques ]
    4. <INCLURE{fond=inc-rubriques}>
    5.  
    6. #FORMULAIRE_RECHERCHE
    7.  
    8. </div><!--#navigation-->
    9.  
    10. [(#REM) Menu de navigation laterale ]
    11. <div id="extra">
    12.  
    13. [(#REM) Inscription au site ]
    14. #FORMULAIRE_INSCRIPTION
    15.  
    16. </div><!--#extra-->

    Télécharger


  • < #11 > Balise meta de la page d'accueil ˆ
    par aleks - 8 novembre 2011 17:04

    TU as un oubli dans le code à la balise meta. La syntaxe correcte devrait-être celle-ci :

    1. [<meta name="description" content="(#DESCRIPTIF_SITE_SPIP|couper{150}|textebrut)" />]

  • < #12 > Balise meta de la page d'accueil ˆ
    par vince - 8 novembre 2011 17:07

    @Emmanuel : merci de m’aider à nouveau.
    je viens de copier
    http://www.tragopan-asie.com/plugins/zpip/sommaire.html
    vers
    http://www.tragopan-asie.com/squelettes/
    (en renommant l’ancien en sommaire.html0)

    et j’ai récupéré la page d’accueil normale (après avoir dû vider le cache :/

    merci beaucoup !
    reste plus qu’a résoudre le problème des balises meta


  • < #13 > Balise meta de la page d'accueil ˆ
    par vince - 8 novembre 2011 17:23
    @Aleks
    merci de te joindre à mes ennuis... j'ai copié ce code :


    <cadre class='html4strict'>
    [#REM) Description]
    [<meta name="description" content="(#DESCRIPTIF_SITE_SPIP|couper{150}|textebrut)" />]
    </cadre>


    dans /squelettes/inc-head.html
    mais ça ne rajoute pas de meta description sur ma page d'accueil. (j'ai revidé le cache spip pour être sûr...)

  • < #14 > Balise meta de la page d'accueil ˆ
    par Emmanuel - 8 novembre 2011 17:34

    Pour savoir où il faut placer le code

    [#REM) Description]
    [<meta name="description" content="(#DESCRIPTIF_SITE_SPIP|couper{150}|textebrut)" />]

    , il faut regarder dans le fichier sommaire.html.

    Ce fichier sommaire.html contient :
    <INCLURE{fond=structure}{env}{type=page}{composition=sommaire} />
    Donc cela veut dire qu’on inclut le fichier structure dans le fichier sommaire.html.

    Regardons donc le fichier structure.html :
    <INCLURE{fond=inclure/head,env}>
    On voit ici qu’il nous faut regarder dans le répertoire www.tragopan-asie.com/squelettes/inclure/ , le fichier head.html.

    C’est dans le fichier www.tragopan-asie.com/squelettes/inclure/head.html qu’il faut ajouter le code.


  • < #15 > Balise meta de la page d'accueil ˆ
    par aleks - 8 novembre 2011 17:37

    Normalement c’est plutôt à copier dans sommaire, les autres squelettes affichant la description qui les concerne (rubrique, article) et non celle du site.

    La description du site est-elle remplie dans l’espace privé ?


  • < #16 > Balise meta de la page d'accueil ˆ
    par vince - 8 novembre 2011 17:57

    alors (après un black-out chez ovh, me revoilà)

    si j’inclue le code dans squelettes/inclure/head.html

    1. [(#REM) Fierement fabrique avec SPIP ]
    2. <meta name="generator" content="SPIP[ (#SPIP_VERSION)]" />
    3.  
    4. [(#REM) Description]
    5. [<meta name="description" content="(#DESCRIPTIF_SITE_SPIP|couper{150}|textebrut)" />]
    6.  
    7. [(#REM) Lien vers le flux RSS du site ]
    8. [<link rel="alternate" type="application/rss+xml" title="<:syndiquer_site:>" href="(#URL_PAGE{backend})" />]

    Télécharger

    - > toujours rien (et je vide le cache systématiquement) (mais en lisant la source depuis firefox, là où devrait se trouver le meta description il y a un maintenant un espace vide (???) entre le meta "generator" et le RSS qui ne se trouvait pas avant l’ajout du code...

    je suis vraiment une tanche parce que je ne vois rien qui ressemble à "description du site" dans l’espace privé.

    dans mon squelettes/sommaire.html j’ai ça :

    1. [(#REM)
    2.  
    3. La page d'accueil est la première page du site.
    4. Elle s'affiche lorsque l'on ecrit l'adresse du site
    5. dans la barre du navigateur.
    6. (...)
    7.  
    8. Allez découvrir ce fameux fichier structure.html.
    9.  
    10. ]
    11. <INCLURE{fond=structure}{env}{type=page}{composition=sommaire} />

    Télécharger

    merci à tous les 2 de pas lâcher l’affaire...


  • < #17 > Balise meta de la page d'accueil ˆ
    par Emmanuel - 8 novembre 2011 18:11

    Bon, bien, c’est presque parfait.

    Effectivement, il faut remplir la "description du site" qu’on trouve en cliquant sur l’icône "Configuration"

    Là, on trouve (entre autre) :
    Nom de votre site
    Adresse (URL) du site public
    Description du site


  • < #18 Balise meta de la page d'accueil ˆ
    par vince - 8 novembre 2011 18:18

    Ca marche !
    Merci encore. j’ai appris plein de choses sur spip.
    Bravo à la communauté !




Répondre à la question

« Balise meta de la page d'accueil »

Mots-clés

Vous pouvez étiqueter cette page de forum avec les mots-clés qui vous semblent les plus appropriés ; ils permettront aux prochains visiteurs du site de mieux se repérer :


Installation, mise à jour

Utilisation de l’espace privé

Administration, gestion, configuration du site

Créer ses squelettes

Qui êtes-vous ?

  • creer ou bien modifier son article côté public via un modèle

    par Laëtitia
    22 juillet 18:16

    Résolu - Réponse(s) : 4

    Je remarque une chose, si il y a 1 document dans le portfolio du rédacteur il peut en charger d’autres sur sa page publique, mais c’est quand il n’y en a pas encore que le chargement ne se fait pas (...)

  • afficher valeurs par ordre croissant

    par Didine
    20 juillet 08:47

    Pas de réponse

    Bonjour, j’utilise le plugin champs supplémentaires. Je récupère dans une liste le contenu de certains champs pour faire un formulaire de tri. Tout fonctionne correctement, cependant dans le select (...)

  • pb spip/spipr et test robots google

    par Didine
    19 juillet 20:07

    Résolu - Réponse(s) : 7

    Bonjour, je suis désolée mais le problème est de retour sur ce site alors que ça fonctionnait après notre échange. Le problème se pose sur plusieurs sites SPIP... peut-être est-ce dû aux modifications (...)

  • Probleme avec mediabox spip3.1.6

    par b_b
    18 juillet 15:28

    Réponse(s) : 6

    Voilà pourquoi je demandais un lien à chti47 :) Sans quoi on va tous passer du temps à jouer aux devinettes, alors que ça pourrait être réglé en 5 minutes (ce qui ferait gagner du temps aux personnes (...)

  • Appeler squelette

    par Mickael
    17 juillet 19:26

    Résolu - Réponse(s) : 2

    Ok, effectivement j’ai des articles qui ont perdu leur affectation :s, du coup je me retrouve avec une rubrique vide... Merci beaucoup

  • Update de la table auteurs

    par Luc
    17 juillet 11:25

    Réponse(s) : 3

    Merci, mais en fait je n’ai aucun problème à afficher les auteurs connectés en récupérant les infos de la table auteurs ; ce que je cherche, c’est faire en sorte que les auteurs connectés updatent la (...)

  • Galerie d'image lightbox slider adaptable

    par Jhessy
    12 juillet 09:57

    Réponse(s) : 2

    Bonjour Philivert, Je sais que le portfolio le fait déjà mais je dois faire cela de cette manière la car c’est dans le cahier des charges de mon stage. Et comme mon problème (en générale) c’est (...)

  • plugin SAISIES & messages d'erreur

    par Keny972
    7 juillet 14:57

    Pas de réponse

    Bonjour, J’utilise en local le plugin SAISIES pour gérer un formulaire de création d’objet éditorial. Je cherche comment ajouter à un champ SAISIES une span message_erreur ? Pas le message (...)

  • INCLUDE et cache

    par Erka
    6 juillet 18:23

    Résolu - Réponse(s) : 4

    Problème résolu : https://www.mail-archive.com/spip@rezo.net/msg72338.html

  • Problème recuperation site en ligne en local

    par Pathé
    6 juillet 17:07

    Résolu - Réponse(s) : 13

    Problème résolu merci !

  • Messages : 29323
  • 8200 43 %
  • Poser une nouvelle question