[ar] [ca] [cpf] [de] [en] [es] [fr] [it]

Ce forum d’entraide est recommandé pour les utilisateurs et utilisatrices occasionnels de SPIP (Système de publication pour l’Internet). Avant de poser une question, faites une recherche sur ce site, consultez les liens utiles. Si vous ne trouvez pas de réponse, postez votre message dans la rubrique appropriée, avec un titre explicite.

Sujets : 24108 Sujets résolus :  39 %

60 visiteurs en ce moment


Accueil > Forums de discussion >  Installation, mise-à-jour > pb accès espace privé : login interdit...

pb accès espace privé : login interdit...

par Dace - 3 janvier 2009 16:52 - Réponse(s) : 82

Bonjour à tous,

j’avais un site spip 1.9.2d et j’ai essayé une mise à jour vers 2.0.2. j’ai uploadé tous les fichiers de la nouvelle version et je voulais me connecter dsd l’espace privé mais là Surprise !!!

il me demande mon login et mot de passe et quand je rentre les bons identifiants, il me mets : "login : Accès interdit"

Aucun moyen de finir la mise à jour...

Merci pour votre aide...


  • #1 > pb accès espace privé : login interdit... ˆ
    par Abdou74100 - 3 janvier 2009 20:32

    Me concernant, c’est de même :( Je vais provisoirement passer à l’ancienne version et faire la Maj ensuite..


  • < #2 > pb accès espace privé : login interdit... ˆ
    par Dace - 3 janvier 2009 20:34

    j’ai réglé mon soucis en supprimant les dossiers tmp et cache-vignettes et en les recréant en leur assignant un chmod 777...

    le pb c’est qu’à chaque fois que je vide le cache, je dois recréer ce dossier cache-vignettes.. autant dire que c’est pénible..

    qqn aurait-il une solution ?


  • < #3 > pb accès espace privé : login interdit... ˆ
    par seb - 4 janvier 2009 22:38

    C’est très étrange... Je viens d’installer la version 2 juste pour voir et pas moyen d’accèder (login : accès interdit) donc pas moyen de rentrer !

    J’ai effacé le /tmp et recréé mais cela ne change rien.


  • < #4 > pb accès espace privé : login interdit... ˆ
    par onaiel - 5 janvier 2009 13:52

    même souci que vous autres.

    sur une nouvelle installation de SPIP, directement en 2.0.2.

    L’installation s’est bien passée mais impossible de me connecter en admin. J’ai pu changer mon mdp via "mot de passe oublié", donc mon compte existe bien, mais à chaque tentative de connexion j’ai "login : Accès interdit".

    help


  • < #5 > pb accès espace privé : login interdit... ˆ
    par Lujayne - 6 janvier 2009 12:59

    Je ne sais pas pour vous, mais pour moi ce problème a été résolu en désactivant le Safe_mode de PHP (demandez à vos hébergeurs de le faire, eux comprendront si vous ne comprenez pas).


  • < #6 > pb accès espace privé : login interdit... ˆ
    par onaiel - 6 janvier 2009 13:12

    oui c’est ce dont je me suis aperçu hier soir. Je voulais poster un message à ce propos. La procédure est en cours, je vous tiens au courant si ça marche...


  • Perso j’ai le Safe_mode à Off et j’ai la même erreur.

    Parcontre quand je supprime "temp" et que je le recreer en 777 ca marche...

    (je suis en mutualisé OVH)


  • < #8 > pb accès espace privé : login interdit... ˆ
    par onaiel - 6 janvier 2009 16:15

    bon toujours pas de réponse de l’hébergeur.

    par contre, en supprimant le dossier tmp et en le recréant en chmod 777, j’ai le même pb...


  • < #9 > pb accès espace privé : login interdit... ˆ
    par onaiel - 6 janvier 2009 17:00

    bon j’ai résolu mon problème tout en ayant le safe_mode en on.

    grâce à Lp dans ce topic

    lp*
    17 décembre 2008 08:35

    Solution

    Le problème viens des autorisations des dossiers : "cache" et "sessions" dans la racine "tmp" il faut les supprimer et ensuite les recréer et redéfinir leurs autorisation qui doit être en 777. Ensuite vous pourrez normalement vous connecter dans la partie administration


  • < #10 > pb accès espace privé : login interdit... ˆ
    par oulala.net - 11 janvier 2009 01:23

    ça ne résoud rien du tout. j’ai fait toutes les manips décrites dans ce forum et j’en arrive toujours au même message d’erreur : login interdit.

    Personne n’a la solution ?

    Merci


  • il n’y a pas une solution.
    cela dépend de :
    - l’hébergeur
    - la configuration safe_mode du serveur
    - le type de mise à jour effectuée (dépôt ftp ou spip_loader)
    - la version du spip d’origine (n° svn)
    - la version du spip de mise à jour (n° svn)
    - l’utilisation de plugins (noms, versions)
    - l’utilisation d’un répertoire perso squelettes/
    - l’utilisation de fichiers de configuration perso (mes_fonctions.php et mes_options.php)


  • < #12 > pb accès espace privé : login interdit... ˆ
    par oulala.net - 11 janvier 2009 20:50

    ça fait beaucoup de "si" et d’hypothèses.
    Il est donc urgent d’attendre que la version 2 soit compatible avec les hébergeurs. C’est ma conclusion après avoir passé plus de 20 heures à galérer.
    Je suis hébergé chez Nfrance depuis plus de 10 ans et je n’ai jamais eu de problème avec toutes les versions de SPIP, jusqu’à la 2, ni avec quelque autre outil que ce soit.
    Je me dis : heureusement que je n’ai pas fait une mise à jour du site opérationel, mais un essai sur un espace disponible.


  • < #13 > pb accès espace privé : login interdit... ˆ
    par oulala.net - 12 janvier 2009 17:35

    Bonjour,

    Vu avec mon hébergeur : Nfrance.com.
    Spip 2 ne peut fonctionner qu’avec le Safe_mode off.
    Outre le fait que cela pose des problèmes de sécurité pour les hébergeurs, Nfrance propose la migration gratuite sur un serveur dont le Safe_Mode est désactivé. "Amanda3" pour les intimes.
    C’est la solution que j’ai retenue et qui sera mise en œuvre dans les prochains jours.

    Inutile, donc, de passer des heures, comme je l’ai fait, à tenter de faire fonctionner Spip 2 sur un hébergement qui n’offre pas le Safe_mode off.
    La modification des droits en écriture sur "temp", etc ; et la recréation de "dossiers" et "sous dossiers" n’y feront rien.

    Je regrette, toutefois, que cette information capitale n’ait pas été donnée lors de la sortie de Spip2 notamment dans le fichier "install.txt".


  • < #14 > pb accès espace privé : login interdit... ˆ
    par Committo, Ergo Sum - 13 janvier 2009 11:31

    Comme l’indique le message du 6 Janvier, SPIP peut marcher en Safe_mode On,
    l’hébergeur a fait une réponse à la louche. De plus, lorsque SPIP rencontre un problème d’accès en écriture en général il le dit clairement, le message Accès interdit étant normalement réservé à des auteurs déchus ou ce genre de chose.

    Dans le répertoire tmp, il y a un sous-répertoire sessions qui est utilisé au moment du login, a-t-il bien été détruit lui aussi avant l’installation ? Avec le safe_mode, il faut absolument que les répertoires tmp/ local/ IMG/ et /config soient vides.


  • Je suis chez NFrance et je viens d’installer la version SPIP 2.0.3. Moi aussi je n’arrive pas à me connecter à l’espace privé même après avoir vidé les répertoires tmp/ local/ IMG/ et /config mais là il faut recommencer la procédure d’installation.

    C’est exact que le message "Accès interdit" arrive après avoir fait quelques essais infructueux de connexion et que notre compte se trouve déchu

    Dois-je demander à NFrance de passer sur un serveur dont le Safe_Mode est désactivé comme oulala.net l’a fait ???


  • < #16 > pb accès espace privé : login interdit... ˆ
    par oulala.net - 15 janvier 2009 23:05

    La seule solution consiste à demander à désactiver le Safe_mode.
    C’est gratuit, mais Nfrance va vous demandera de signer une décharge qui engage votre responsabilité.
    Personnellement je ne l’ai pas signée et je renonce à la version 2 en attendant une hypothétique solution venant des développeurs de SPIP... ou la version 6 de PHP qui va définitivement supprimer le Safe_mode.


  • N’y aurait-il pas un autre problème car je vois dans le fil de la discussion que certains arrivent à régler le problème quelque soit l’état du Safe_mode

    Sinon je vais aussi attendre la nouvelle version de PHP :(


  • < #18 > pb accès espace privé : login interdit... ˆ
    par oulala.net - 16 janvier 2009 14:38

    Moi je n’y suis pas arrivé, mais si quelqu’un a la solution, je suis preneur....

    Il est vrai que beaucoup d’hébergeurs laissent le Safe_mode en off... avec les conséquences que cela peut avoir sur la sécurité.

    Moi, la question que je pose et à laquelle je n’ai jamais eu de réponse , c’est : pourquoi avoir développé un produit qui impose le Safe_mode off alors que les versions de PHP installées sur la totalité des hébergeurs, sérieux, requierent le Safe_mode on ?

    Ne pas avoir de réponse de l’équipe de développeurs me pose problème, aussi.


  • < #19 > pb accès espace privé : login interdit... ˆ
    par Committo, Ergo Sum - 16 janvier 2009 14:47

    J’ai pourtant déjà répondu sur ce fil que SPIP peut marcher en SafeMode On, le problème est ailleurs mais les informations données ne me permettent pas d’aider plus. .


  • < #20 > pb accès espace privé : login interdit... ˆ
    par oulala.net - 16 janvier 2009 15:11

    je recommence pour commito :

    Installation propre sur un espace business serveur Nfrance.
    Importation d’une base de donnée générée en local (malheureusement au format ISo mais c’est pas le plus grave).

    Tout fonctionne sur l’espace public : www.netmulot.net

    Essai d’entrer dans l’espace privé :

    1er problème : login interdit.
    Manip : re-création des répertoires et sous répertoires comme indiqué dans ce forum.

    2 ème problème : Fatal error : Call to undefined function : imagegif() in /homexx/mxxxx/vos-pages-html/ecrire/inc/filtres_images_mini.php on line 215

    Impossible d’aller plus loin. Il semblerait que Spip refuse d’écrire dans le répertoire "tmp". il est bien en 777.

    J’ai vérifié tous les droits en écriture.


  • < #21 > pb accès espace privé : login interdit... ˆ
    par Committo, Ergo Sum - 16 janvier 2009 15:26

    On mélange les problèmes là.
    Le cas de la version de PHP qui n’a même pas imagegif a déjà été signalé dans le forum (il faut utiliser le moteur de recherche, on ne peut pas écrire des milliers de fois les mêmes réponses). Une fois n’est pas coutume, je redonne ici la
    modification à faire.

    Cela dit, le résultat ne sera pas terrible graphiquement, on travaille à une version plus robuste face à une version de PHP aussi légère. Mais là l’hébergeur pourrait faire un effort, la disponibilité de imagegif ne pose aucun problème de sécurifé.


  • Moi je transfère spip. Je me connecte à ecrire/ Je configure la base
    J’essaie de rentrer dans l’espace privé.J’ai

    "Vous avez tenté d’accéder à l’espace privé avec un login qui ne le permet pas."

    et pas moyen d’accéder à l’espace privé par contre j’ai la page d’accueil :

    http://www.lalibertedelesprit.org/spip/


  • < #23 > pb accès espace privé : login interdit... ˆ
    par Committo, Ergo Sum - 16 janvier 2009 15:56

    Etrange, le message semble dire que le compte administrateur a été créé avec le statut de visiteur. C’est une installation tout neuve, ou bien la base avait elle déjà quelque chose ?


  • < #24 > pb accès espace privé : login interdit... ˆ
    par Alain BOURDEAU - 16 janvier 2009 16:08

    Bonjour,
    Si il y a un fichier login.php dans la directorie squelettes ou en sous directorie c’est cette procédure qui est lancée mais comme spip 2.0.x travaille autrement - plus de sécurité - ça coince. Donc neutraliser ce fichier dans squelettes.


  • J’ai eu ça à la première installation puis j’ai retranféré les fichiers et effacé les tables, pour avoir encore ce blocage
    — 

    Il n’y a pas de fichier login.php dans le répertoire squelette ou ses sous-répertoires


  • Dans la table auteurs le compte a le statut 0minirezo


  • < #27 > pb accès espace privé : login interdit... ˆ
    par Committo, Ergo Sum - 16 janvier 2009 16:34

    [ N’oubliez pas de mettre vos pseudos dans les envois, le fil devient incompréhensible ].

    Peux-tu communiquer le contenu de tmp/spip.log juste après ce refus d’accès (n’oublie pas d’utiliser le bouton de citation de code pour que ce soit lisible).


  • < #28 > pb accès espace privé : login interdit... ˆ
    par oulala.net - 16 janvier 2009 16:42

    Pour commito :

    Comment on utilise ce fichier ? fichier pour la correction

    merci


  • < #29 > pb accès espace privé : login interdit... ˆ
    par Committo, Ergo Sum - 16 janvier 2009 16:46

    Ca dit où rajouter 3 lignes dans le fichier indiqué.

    ce format est peut-être plus lisible


  • < #30 > pb accès espace privé : login interdit... ˆ
    par oulala.net - 16 janvier 2009 17:30

    De Oulala.net à Commito

    Ok cette fois ça marche. Ouf !
    Par contre l’accès à l’espace privé est anormalement lent.

    Je finis le test et je donne la solution à Nfrance pour en faire profiter la communauté.

    Merci
    www.oulala.net


  • < #31 > pb accès espace privé : login interdit... ˆ
    par oulala.net - 16 janvier 2009 17:33

    Pour commito.

    le cache reste désespérément vide.


  • désolé pour le speudo, j’avais supprimé les cookies pour voir et après j’ai pas vu que je n’étais plus connecté
    — 

    Voici la fin du fichier php.log à la création du site

    Jan 16 17:25:20 82.245.204.7 (pid 21216) spip_connect: absence de charset
    Jan 16 17:25:20 82.245.204.7 (pid 21216) fonction execute_pipeline_affichage_final absente : pipeline desactive
    Jan 16 17:30:48 82.245.204.7 (pid 21864) spip_register_globals(1)
    Jan 16 17:30:48 82.245.204.7 (pid 21864) echec creation tmp/cache/e
    Jan 16 17:30:48 82.245.204.7 (pid 21864) echec creation tmp/cache/skel
    Jan 16 17:30:48 82.245.204.7 (pid 21864) COMPIL (0.075s) [prive/login] html_62bbcc138b9987df2823dedcbf7d6fbd.php
    Jan 16 17:30:48 82.245.204.7 (pid 21864) calcul (0.039s) [prive/login] page=login, url=/spip/ecrire/?exec=accueil, lang=fr, date='2009-01-16 17:30:48', date_redac='2009-01-16 17:30:48' (1940 octets)
    Jan 16 17:30:48 82.245.204.7 (pid 21864) fonction execute_pipeline_insert_js absente : pipeline desactive
    Jan 16 17:30:48 82.245.204.7 (pid 21864) fonction execute_pipeline_insert_js absente : pipeline desactive
    Jan 16 17:30:48 82.245.204.7 (pid 21864) Creation du cache log-log-%2Fsp-fr--1b9a92e55d60b42 pour 86400 secondes (erreur!)
    Jan 16 17:30:48 82.245.204.7 (pid 21864) echec creation tmp/cache/7
    Jan 16 17:30:48 82.245.204.7 (pid 21864) echec creation tmp/cache/skel
    Jan 16 17:30:48 82.245.204.7 (pid 21864) COMPIL (4.0ms) [prive/formulaires/menu_lang] html_b61975450fb501cd7fcc10ad2098653c.php
    Jan 16 17:30:48 82.245.204.7 (pid 21864) calcul (0.011s) [prive/formulaires/menu_lang] nom=var_lang_ecrire, url=http://www.lalibertedelespr.., langues='<option class='maj-debut' v..', lang=fr, date='2009-01-16 17:30:48', date_redac='2009-01-16 17:30:48' (3602 octets)
    Jan 16 17:30:48 82.245.204.7 (pid 21864) Creation du cache for-lan-var-lan-ecr-htt--96562ad6 pour 3600 secondes (erreur!)
    Jan 16 17:30:48 82.245.204.7 (pid 21864) echec creation tmp/cache/7
    Jan 16 17:30:48 82.245.204.7 (pid 21864) echec creation tmp/cache/skel
    Jan 16 17:30:48 82.245.204.7 (pid 21864) COMPIL (0.028s) [prive/formulaires/login] html_e53d9ed2b7e1ba4fbec99b074db0706b.php
    Jan 16 17:30:48 82.245.204.7 (pid 21864) calcul (3.3ms) [prive/formulaires/login] rester_connecte=' ', _hidden='<input type="hidden" name="..', form=login, action=spip.php?page=login&url.., formulaire_args=drni0jFkczh7kctA3Cr34tvArcO.., id=new, editable=' ', lang=fr, date='2009-01-16 17:30:48', date_redac='2009-01-16 17:30:48' (2574 octets)
    Jan 16 17:30:48 82.245.204.7 (pid 21864) Creation du cache for----%20----%3Cin-pas--e9c278f7 pour 3600 secondes (erreur!)
    Jan 16 17:30:57 82.245.204.7 (pid 22074) spip_register_globals(1)
    Jan 16 17:30:57 82.245.204.7 (pid 22074) echec creation tmp/cache/c
    Jan 16 17:30:57 82.245.204.7 (pid 22074) echec creation tmp/cache/skel
    Jan 16 17:30:58 82.245.204.7 (pid 22074) COMPIL (0.020s) [prive/informer_auteur] html_69572f7b1b11fa45a79976555c467c27.php
    Jan 16 17:30:58 82.245.204.7 (pid 22074) echec creation tmp/cache/c
    Jan 16 17:30:58 82.245.204.7 (pid 22074) echec creation tmp/cache/skel
    Jan 16 17:30:58 82.245.204.7 (pid 22074) COMPIL (5.6ms) [prive/formulaires/inc-logo_auteur] html_7b696bceaac664854caceeb97b4d03a3.php
    Jan 16 17:30:58 82.245.204.7 (pid 22074) calcul (1.6ms) [prive/formulaires/inc-logo_auteur] id_auteur=1, login=bantegnie, alea_futur=21232825974970b633c9f676.85.., source=spip, lang=fr, date='2009-01-16 17:30:58', date_redac='2009-01-16 17:30:58' (1 octets)
    Jan 16 17:30:58 82.245.204.7 (pid 22074) Creation du cache for-log-aut-1-ban--21232-2c3f0c16 pour 86400 secondes (erreur!)
    Jan 16 17:30:58 82.245.204.7 (pid 22074) calcul (0.034s) [prive/informer_auteur] page=informer_auteur, date='2009-01-16 17:30:58', date_redac='2009-01-16 17:30:58' (110 octets)
    Jan 16 17:30:58 82.245.204.7 (pid 22074) Creation du cache inf-aut-inf-aut--3904d8b317d7eac4 pour 0 secondes (erreur!)
    Jan 16 17:31:03 82.245.204.7 (pid 21864) spip_register_globals(1)
    Jan 16 17:31:03 82.245.204.7 (pid 21864) demande de creation de tmp//.htaccess
    Jan 16 17:31:03 82.245.204.7 (pid 21864) connexion de bantegnie par methode spip
    Jan 16 17:31:03 82.245.204.7 (pid 21864) faux sous-repertoire tmp/sessions
    Jan 16 17:31:03 82.245.204.7 (pid 21864) ajoute session tmp/sessions1_ad5d57b8405611dfd1b21603e63d3c7a.php cookie 864000
    Jan 16 17:31:03 82.245.204.7 (pid 21864) echec creation tmp/cache/skel
    Jan 16 17:31:03 82.245.204.7 (pid 21864) COMPIL (0.030s) [prive/login] html_62bbcc138b9987df2823dedcbf7d6fbd.php
    Jan 16 17:31:03 82.245.204.7 (pid 21864) calcul (0.011s) [prive/login] page=login, url=/spip/ecrire/?exec=accueil, lang=fr, formulaire_action=login, formulaire_action_args=drni0jFkczh7kctA3Cr34tvArcO.., password=renejean, date='2009-01-16 17:31:03', date_redac='2009-01-16 17:31:03' (1940 octets)
    Jan 16 17:31:04 82.245.204.7 (pid 21864) echec creation tmp/cache/skel
    Jan 16 17:31:04 82.245.204.7 (pid 21864) COMPIL (4.4ms) [prive/formulaires/menu_lang] html_b61975450fb501cd7fcc10ad2098653c.php
    Jan 16 17:31:04 82.245.204.7 (pid 21864) calcul (0.011s) [prive/formulaires/menu_lang] nom=var_lang_ecrire, url=http://www.lalibertedelespr.., langues='<option class='maj-debut' v..', lang=fr, date='2009-01-16 17:31:04', date_redac='2009-01-16 17:31:04' (3602 octets)
    Jan 16 17:31:04 82.245.204.7 (pid 21864) echec creation tmp/cache/skel
    Jan 16 17:31:04 82.245.204.7 (pid 21864) COMPIL (4.7ms) [prive/formulaires/inc-logo_auteur] html_7b696bceaac664854caceeb97b4d03a3.php
    Jan 16 17:31:04 82.245.204.7 (pid 21864) calcul (1.2ms) [prive/formulaires/inc-logo_auteur] id_auteur=1, login=bantegnie, alea_actuel=21232825974970b633c9f676.85.., alea_futur=4752914554970b647c855d6.548.., prefs=a:1:{s:3:"cnx";s:0:"";}, source=spip, lang=fr, date='2009-01-16 17:31:04', date_redac='2009-01-16 17:31:04' (1 octets)
    Jan 16 17:31:04 82.245.204.7 (pid 21864) echec creation tmp/cache/skel
    Jan 16 17:31:04 82.245.204.7 (pid 21864) COMPIL (0.140s) [prive/formulaires/login] html_e53d9ed2b7e1ba4fbec99b074db0706b.php
    Jan 16 17:31:04 82.245.204.7 (pid 21864) calcul (9.8ms) [prive/formulaires/login] var_login=bantegnie, rester_connecte=' ', _alea_actuel=21232825974970b633c9f676.85.., _alea_futur=4752914554970b647c855d6.548.., _hidden='<input type="hidden" name="..', form=login, action=spip.php?page=login&url.., formulaire_args=drni0jFkczh7kctA3Cr34tvArcO.., id=new, erreurs=a:1:{s:14:"message_erreur";.., message_erreur='<h1>Probl&egrave;me d'acc&e..', editable=' ', lang=fr, date='2009-01-16 17:31:04', date_redac='2009-01-16 17:31:04' (3131 octets)
    Jan 16 17:31:57 82.245.204.7 (pid 22174) spip_register_globals(1)
    Jan 16 17:31:58 82.245.204.7 (pid 22174) connexion de bantegnie par methode spip
    Jan 16 17:31:58 82.245.204.7 (pid 22174)  login&nbsp;: Acc&egrave;s interdit /spip/spip.php?page=login&url=%2Fspip%2Fecrire%2F%3Fexec%3Daccueil

  • < #33 > pb accès espace privé : login interdit... ˆ
    par Committo, Ergo Sum - 16 janvier 2009 17:58

    Ok, alors le vrai problème est que la fonction "mkdir", qui permet de créer des sous-répertoires, ne fonctionne pas. SPIP essaye de s’en sortir sans elle, mais ça fait très longtemps qu’on n’a pas ré-examiné ce cas tellement ça n’a pas de sens de l’empêcher de fonctionner. Demander à l’hébergeur de l’activer. Si pas possible, j’essaierai de voir pourquoi la solution alternative ne marche plus en 2.0. Mais même au cas où j’ai le temps de remettre ça sur pied, il faut bien voir que ne pas pouvoir créer de sous-répertoire n’est pas sans incidence sur les perfs.


  • ReunigKozh :
    peux-tu faire un petit test ?

    créer (format texte seul, 8 lignes) un fichier de test (tester_dir.php) :

     
    <?php
    error_reporting(E_ALL);
    ini_set ("display_errors", "On");
    $crea = mkdir('rep_tst');
    $fp   = fopen('rep_tst/fic_tst.txt', 'w');
    fwrite($fp, 'coucou');
    fclose($fp);
    ?>

    le déposer à la racine de ton spip, puis l’appeler par http://le_site/tester_dir.php

    ensuite, par ftp, regarder si tu as bien un répertoire rep_tst/ contenant un fichier fic_tst.txt que tu peux afficher dans ton navigateur : http://le_site/rep_tst/fic_tst.txt


  • Warning: mkdir(rep_tst) [function.mkdir]: Permission denied in /home/ju25182/test.php on line 4

    Warning: fopen(rep_tst/fic_tst.txt) [function.fopen]: failed to open stream: No such file or directory in /home/ju25182/test.php on line 5

    Warning: fwrite(): supplied argument is not a valid stream resource in /home/ju25182/test.php on line 6

    Warning: fclose(): supplied argument is not a valid stream resource in /home/ju25182/test.php on line 7

  • Autre test dans un répertoire en 777

    Warning: fopen() [function.fopen]: SAFE MODE Restriction in effect. The script whose uid is 2239 is not allowed to access /home/ju25182/test/rep_tst owned by uid 80 in /home/ju25182/test/index.php on line 5

    Warning: fopen(rep_tst/fic_tst.txt) [function.fopen]: failed to open stream: No such file or directory in /home/ju25182/test/index.php on line 5

    Warning: fwrite(): supplied argument is not a valid stream resource in /home/ju25182/test/index.php on line 6

    Warning: fclose(): supplied argument is not a valid stream resource in /home/ju25182/test/index.php on line 7

  • The script whose uid is 2239 is not allowed to access /home/xxxx/rep_tst owned by uid 80

    ça s’apparente donc bien à un problème de propriétaire de fichiers et pas seulement de droits d’accès.

    donc à un réglage des options safe_mode et safe_mode_gid par l’hébergeur.

    sinon, pour oulala.net, spip 2.0.3 tourne parfaitement sur un hébergement avec un safe_mode à on : http://www.circaete.net/vrac/safe_spip2.jpg


  • Pour ma part j’ai ces paramètres

    Directive                Local Value        Master Value
    safe_mode                On                On
    safe_mode_exec_dir        /safe-bin        /safe-bin
    safe_mode_gid                Off                Off
    safe_mode_include_dir        no value        no value

    Que faut-il demander à l’hebergeur ?


  • < #39 > pb accès espace privé : login interdit... ˆ
    par oulala.net - 16 janvier 2009 21:40

    Oui, tout fonctionne sur le site de test de Oulala.net à cette adresse : www.netmulot.net
    Il reste quelques petits problèmes d’affichage dans l’espace privé au niveau des boutons. Le texte ne s’affiche pas dans les boutons !

    Par contre, malgré la création des répertoires et des fichiers dans le répertoire tmp/cache, la taile du cache n’apparait pas dans l’espace privé :
    /ecrire/ ?exec=admin_vider

    Avant de passer à la mise a jour du site de production je vais refaire un essai en reprenant la procédure depuis le début.

    Qui a une soluce pour convertir une base de ISO à UTF-8 ?


  • Quels sont les répertoire et fichiers à créer ?


  • pour ce qui est de nfrance, ils ont une page explicative ici :
    http://wiki.nfrance.com/pro:mutualises:safe_mode
    où ils proposent d’utiliser ftp_mkdir() ...


  • J’ai trouvé mkdir dans ces quatre fichiers dans ecrire/inc/

    flock.php
    ajouter_documents.php
    math.php
    pclzip.php

    Il me suffit donc de remplacer chaque occurence de mkdir par ftp_mkdir


  • je ne sais trop...
    il pourrait y avoir des effets de bord.
    et puis, il n’y a pas que mkdir() qui est touché par les restrictions de safe_mode.
    attendons sagement ce que pourrait en dire comitto.


  • Le remplacement de mkdir par ftp_mkdir n’est pas automatique et j’ai l’impression qu’il doit demander quelques lignes de code supplémentaires ?


  • < #45 > pb accès espace privé : login interdit... ˆ
    par DD23 - 19 janvier 2009 22:02

    J’ai eu le même problème que vous et viens de le résoudre à l’instant en faisant cette manipe trouvé sur le forum :

    lp*
    17 décembre 2008 08:35

    Solution

    Le problème viens des autorisations des dossiers : "cache" et "sessions" dans la racine "tmp" il faut les supprimer et ensuite les recréer et redéfinir leurs autorisation qui doit être en 777. Ensuite vous pourrez normalement vous connecter dans la partie administration


  • J’ai essayé cette manip mais chez NFrance ça semble ne pas marcher :(


  • < #47 > pb accès espace privé : login interdit... ˆ
    par oulala.net - 19 janvier 2009 22:43

    Pour ce qui est de Nfrance, la solution est ici :

    http://wiki.nfrance.com/generale:cms

    sur le site d’essai de oulala.net à l’adresse : www.netmulot.net ça marche.

    Ne pas oublier de vider le cache et de virer tous les fichiers de sessions.


  • < #48 > pb accès espace privé : login interdit... ˆ
    par jcd31 - 20 janvier 2009 16:41

    MOI AUSSI , J’ai eu le même problème que vous et je viens MOI AUSSI de le résoudre à l’instant en faisant cette manipe trouvé sur le forum :

    je suis chez AMEN et ca marche à present :

    Le problème viens des autorisations des dossiers : "cache" et "sessions" dans la racine "tmp" il faut les supprimer et ensuite les recréer et redéfinir leurs autorisation qui doit être en 777. Ensuite vous pourrez normalement vous connecter dans la partie administration


  • < #49 > pb accès espace privé : login interdit... ˆ
    par Onaiel - 20 janvier 2009 16:54

    Effectivement, c’est cette dernière manip qui m’a permis d’installer SPIP 2.0.2. Sauf que la possibilité d’installer des plugins en automatique (fonctionnalité très pratique pour les MaJ) ne fonctionnait pas. Par ailleurs, j’étais en charge de monter un campus en ligne (Claroline). Et son installation était bloquée par PHP Safe_mode en "on" (en local value je précise, pas en global value - cf phpinfo). J’ai dû donc faire des pieds et des mains pour que mon hébergeur (SelfServeur) change ce Safe_Mode en "off". J’ai pu installer Claroline et depuis mon SPIP accepte sans problème l’installation automatique des plugins.

    Voilà, bonne chance à tous...


  • Ouf ! J’ai réussi.
    J’ai tout effacé et tout recréé et surtout en créant les sous-répertoires de /tmp/cahe.

    En cours d’utilisation est-ce que je risque de me retrouver confronté à un problème identique de sous-répertoire qui ne peut être créé ?


  • comme c’est apparemment un problème de propriété plus que de droits (à savoir un script a-t-il le droit de créer des répertoires dont le propriétaire -dans cette configuration bien particulière- ne serait pas l’utilisateur ftp), tu devras peut-être faire attention aux sous-répertoires de local/cache-vignettes/ : L48xH48, L150xH95... que spip crée automatiquement en fonction de ses besoins.

    les mises à jour automatique de plugins (répertoire plugins/auto/) pourraient aussi ne pas fonctionner.

    merci par avance de nous tenir au courant


  • J’ai transféré un site et j’ai eu ce problème de local/cache-vignettes/ .
    J’ai dû créer quelques répertoires.

    J’espère que je ne vais pas devoir créer ces répertoires chaque fois que je vais alimenter le site....


  • ben, pour le coup...

    mais c’est vraiment une configuration de l’hébergement trés particulière


  • C’est pas possible pour chaque article que je veux afficher je suis obligé de créer plusieurs répertoires dans local/cache-vignettes. J’avais commencé à développer mon site chez Free. Avec la vingtaine d’articles que j’avais créés, je vais y passer la nuit. Je pense que je vais rester chez Free en plus c’est gratuit :o)


  • chrisker de NFrance écrit :

    si vous avez optez pour la dernière version de SPIP, celui-ci impose un environnement safe_mode à off.
    Ce qui n’est pas le cas sur les formules Web1 Basic.
    C’est dans ce cas un Web1 Pack qu’il vous faut.

    Dois-je payer plus pour que mon spip fonctionne ?


  • sauf que ce qui est dit dans le forum que tu cites est faux !

    spip 2.0.3 fonctionne sur un serveur configuré avec le SAFE_MODE en ON.

    (je me répète : http://www.circaete.net/vrac/safe_spip2.jpg)


  • J’ai pu dire sur le forum d’aide de NFrance que spip devait fonctionner avec safe_mode à ON mais pour l’instant ça n’a pas l’air d’intéresser grand monde

    http://forum.nfrance.com/p21409-Aujourd%27hui-00%3A37%3A22.html#p21409

    Je constate que je suis en PHP Version 4.4.8. Est-ce que mes problèmes sous SPIP ne viendraient pas de cette version ?

    http://www.lalibertedelesprit.org/info.php


  • pour info : la configuration de ce type d’hébergement chez nfrance cause problème à l’identique pour d’autre cms que spip...
    http://forum.joomla.fr/archive/index.php/t-30986.html


  • Chez FREE le même site en SPIP ne me pose pas de problème et je constate qu’ils sont en safe_mode On

    Chez NFrance le problème doit être ailleurs mais où ?


  • tout ça, ce sont des questions à voir avec nfrance.


  • < #62 > pb accès espace privé : login interdit... ˆ
    par Brounch - 21 janvier 2009 17:45

    la solution de onaiel m’a sauvé : supprimez les 2 répertoires /tmp/sessions et /tmp/cache puis recréez-les avec un chmod 777

    je me suis déconnecté et reconnecté depuis sans prob ;-)


  • Moi aussi chez NFrance grâce à cette procédure j’ai pu créer mon site spip et y entrer.
    Mais lorsque j’ai transféré celui que j’ai commencé chez Free, j’ai été confronté à ce problème de répertoire dans local/cache-vignettes/ et j’ai abandonné après avoir fait une dizaine de navette entre blocage, fichier spip.log et création de répertoire.
    Si même je créais une centaine de répertoires pour transférer mon site, est-ce que je serais à l’abri de ce genre de problème en fonctionnement "normal" ???


  • < #64 > pb accès espace privé : login interdit... ˆ
    par oulala - 24 janvier 2009 23:24

    Le cache de Spip 2 reste désespérément vide ( c’est ce qu’affiche la partie privée du site) pourtant ce n’est pas le cas si je me réfère au dossier "local". L’action : "vider le cache" ne produit aucun effet.
    De plus il y a des problème d’affichage de la partie privée et notamment le texte des boutons qui est blanc sur fond blanc.

    Quelqu’un a-t-il rencontré ce problème ?

    www.netmulot.net


  • < #65 > pb accès espace privé : login interdit... ˆ
    par oulala - 25 janvier 2009 20:57

    A la sauvegarde de la base, l’erreur suivante se produit :
    Fatal error : Allowed memory size of 16777216 bytes exhausted (tried to allocate 8447 bytes) in /xxxx/xxx/xxxxl/ecrire/inc/export.php on line 207

    Quelqu’un a-t-il une solution ?

    Pour ma part, je pense que je vais cesser de me bagarrer avec une version qui est loin d’être aboutie pour retourner à la 1.9.


  • je vais cesser de me bagarrer avec une version qui est loin d’être aboutie pour retourner à la 1.9.

    Il faut rappeler que SPIP est fait bénévolement, son équipe ne peut donc s’offrir un abonnement chez chaque hébergeurpour vérification. Cela faisait des semaines que SPIP 2.0 était en pré-version, et que vous avons demandé à chacun de la tester pour résoudre un maximum de problèmes de ce genre avant sa sortie officielle. Pourquoi avoir attendue celle-ci ?


  • < #67 > pb accès espace privé : login interdit... ˆ
    par Arioch - 27 janvier 2009 15:00

    Bonjour à tous

    J’ai rencontré une bonne partie des problèmes que vous évoquez tous.
    Ayant la chance d’avoir un accès root sur le serveur qui héberge mes sites, je me suis rendu compte d’une "bizarrerie" dans les dossiers de SPIP.
    En effet, même en passant les dossiers comme "local" ou "tmp" en mode 777 (tous les droits à tout le monde), Spip n’arrivait pas à écrire dedans.

    Au niveau du système de fichier, le problème était que le . et le .. avaient des autorisations bizarres ...

    Pour résoudre tout cela, voici ce que j’ai fait :
    - ne poser via le ftp que les dossiers ecrire, prive et squlettes-dist ainsi que les fichiers .php de la racine, rien.gif et le .htpassword
    - créer les dossiers config, IMG, local, tmp à la main via le client ftp et leur donner les droits adéquats
    - créer les sous-dossiers dans les dossiers
    Ainsi les dossiers sont créés comme il faut et Spip a bien les droits dessus.

    Et là, miracle, ça marche (à tous les coups dans mon cas).


  • Certaines configurations des serveurs HTTP refusent d’écrire dans des fichiers dont ils ne sont pas propriétaires et qu’il estiment trop ouverts à tout le monde (777). SPIP a introduit la constante _SPIP_CHMOD pour réduire cette ouverture, ça peut être une autre manière de résoudre le problème. Evidemment le problème rencontré est dû au fait que les 4 répertoires vides sont inclus dans la distribution, mais malheureusement d’autres configurations ne permettent pas de créer des répertoires. Etre compatible avec toutes les configurations à la fois relève de la quadrature du cercle.


  • < #69 > pb accès espace privé : login interdit... ˆ
    par oulala - 27 janvier 2009 17:25

    Le bénévolat, je connais et je pratique... puisque je suis ici.

    Le message d’erreur dont je parlais ci-dessus disparait si l’on intègre dans le .htacces la ligne suivante : php_value memory_limit 20M

    Par contre la sauvegarde de la base pose problème avec un message d’erreur en milieu de sauvegarde (vers le 20 ème paquet) puis la sauvegarde se termine mais la base est corrompue puisque mal sauvegardée.

    La solution est de sauvegarder rubrique par rubrique. Mais c’est pas la panacée.

    Il demeure donc (chez nfrance notamment) qu’il y a un problème de droit d’accès à la création des répertoires. Droit d’accès qui ne peut être résolu qu’en créant les répertoires par FTP quand c’est possible.

    Autre particularité, la sauvegarde de la base ne convertit pas les caractères accentués au bon format. Ce qui apparait à l’écran, à la restauration, ressemble à ceci : sottises dégueulées en ton nom ! Le populo manipulé en arrive même

    Je cherche.....


  • inutile d’allonger de thread avec d’autre questionnements qui se retrouvent hors sujet ici.
    mais plutôt ouvrir d’autres fils de discussion (ce sera plus simple par la suite pour s’y retrouver...)

    pour tenter de synthétiser :
    - Fatal error : Allowed memory size ... est bien un message d’erreur qui apparait quand le système ne donne pas assez de mémoire à l’exécution du script (ou que le script demande trop de mémoire au système qui l’héberge...).
    dans le cas de spip 2, il faut lui accorder au moins 12Mo de mémoire (réglage de memory_limit), 16Mo étant un plus évident.
    ce problème de mémoire allouée explique sans doute aussi la perte de connexion pendant la sauvegarde des données.

    - pour les droits sur fichiers : il y a chez certains hébergeurs des configurations qui reposent sur un paramétrage excessivement blindé du safe_mode, alors que ce safe_mode sera supprimé du prochain php6.
    comme l’explique Committo, s’il est vrai que spip est adapté à une installation sur la plupart des configurations d’hébergement existantes, il n’en reste pas moins que dans certains cas, sur certaines config, il faille faire dans la dentelle...
    ce peut être juste de changer les droits (chmod) de certains répertoires, jusqu’à intervenir récursivement à la racine de l’hébergement pour changer le propriétaire des répertoires installés.
    c’est donc du cas par cas et comme les configurations précises sont rarement connues des utilisateurs, il faut bien souvent y aller à tâton.

    - enfin, pour ce qui est des caractères qui changent entre sauvegarde et restauration, le plus souvent, c’est dû au fait que les deux bases ne sont pas encodées dans le même charset, souvent lors de l’import d’une ancienne version dans une base nouvellement créée.
    et là non plus, il n’y a pas une et une seule solution.


  • < #71 > pb accès espace privé : login interdit... ˆ
    par less - 24 février 2009 14:53

    Je rencontre des problèmes de login avec OVH :
    - quand j’installe SPIP 2.0.3 , tout est OK
    - quand je m’identifie, j’accède bien à la partie privée.

    Mais le lendemain, je n’ai plus accès. La page mon_site/ecrire se réaffiche après avoir effacé le Login que j’avais saisis.

    J’ai tout désinstallé (tables SQL et répertoires contenant SPIP) mais après réinstallation, j’ai le même problème, sans message.


  • Exactement... Je suis comme less.
    J’ai installe la mise a jour de 1.9.2 a 2.0.9.
    Au debut tout fonctionne, je rentre dans la partie prive et hop.
    Le soir meme, en rentrant chez moi, je n’ai plus acces a la partie privee.
    Quand je rentre mon login, il recharge la page en la passant en anglais et voila.
    Tout vide, aps de message d’erreurs.

    Une idee ?


  • < #73 > pb accès espace privé : login interdit... ˆ
    par Berroure - 2 septembre 2009 17:55

    Après avoir voulu résoudre le problème de chargement "auto" des plugins, et sur un conseil d’un membre du forum SPIP, j’ai supprimé les fichiers du dossier "tmp". Tout de suite j’ai vu apparaître les sites de téléchargement des plugins, mais lorsque j’ai voulu en activer un, cela n’a pas fonctionné. J’ai donc abandonné, et lorsque j’ai voulu ouvrir mon site, j’ai eu "error403-forbidden" (je ne suis pas sûr que cette manip soit la cause du problème, mais peu importe).
    Après maints essais de recopie par ftp des fichiers que j’avais supprimés, je n’ai rien obtenu.

    Le seul progrès, c’est que lorsque j’ai vidé le dossier "config", j’ai pu reconfigurer spip, pour cette fois avoir "error404" !

    Je vous livre maintenant pour essayer de faire court, ce qui m’a permis de réouvrir l’espace privé de mon site.

    1) j’ai installé à nouveau spip sur mon disque dur

    2) j’ai supprimé par FTP dans mon site qui ne s’ouvre plus, d’une part, les fichiers à la racine et ceux du dossier "config", et d’autre part, les dossiers : "ecrire", "local", "plugins", "prive", "squelettes-dist" et "tmp". J’ai donc gardé les dossiers "IMG", "logs" et "squelettes"

    3) du nouveau dossier spip, j’ai transféré par FTP les fichiers à la racine, puis tous les dossiers supprimés précédemment

    4) j’ai refait mon installation du nouveau spip chez l’hébergeur, et j’ai obtenu l’ouverture de l’espace privé, avec bien entendu aucune configuration de présentation autre que celle de spip par défaut, mais avec tout le contenu de ma base de données qui est restée inchangée

    5) il ne m’est plus resté qu’à réinstaller les plugins par FTP, puisque l’installation auto n’est pas possible en ce moment

    Voilà, c’est un peu long, mais ça marche et tout est rentré dans l’ordre.


  • < #74 > pb accès espace privé : login interdit... ˆ
    par jle@grainedejardins - 3 janvier 2010 00:03

    Même problème d’accès à l’admin simultanément sur deux sites SPIP2.10 installés sur le même hébergement OVH. Après plusieurs vaines manips, j’ai supposé que l’espace d’hébergement était plein (l’info dans le manager OVH n’est pas claire). J’ai gagné un peu de place et les sites fonctionnent à nouveau.

    Voilà un nouveau paramètre à prendre en compte !


  • < #75 > pb accès espace privé : login interdit... ˆ
    par clicasso - 3 janvier 2010 21:30

    Salut,

    Le topic est un peu vieux mais les problèmes restent :) Je me suis penché sur la question de longues heures car j’avais un client qui n’arrivait pas à installer SPIP et ça me semblait un peu louche l’ayant moi même utilisé pour des projets perso. La version 2 me semble avoir de sérieux soucis avec le safe_mode comme de nombreuses personnes l’indique.

    Pour ma part je suis hébergeur de sites web (clicasso) et nous sommes confrontés aux supports des clients. C’est pour ça que j’ai essayé d’approfondir la question. J’ai lu plus haut que c’était une réponse bizarre cette histoire du safe_mode. Je serais tenté de proposer un hébergement gratuit pour la personne qui a dit ça si elle arrive à installer SPIP sur un de mes serveurs sans que je ne touche le safe_mode lol :) !! Plus sérieusement après m’être acharné à supprimer des dossiers, vider le cache, etc... j’en suis arrivé à désactiver le safe_mode le temps de l’installation et ça fonctionne. Ensuite j’ai réactiver le safe_mode, car sinon ça pose de sérieux soucis de sécurité sur la machine, et le SPIP tourne. Par contre le client semble avoir maintenant des soucis avec les modules.

    Je ne suis pas spécialiste de SPIP et c’est pour ça que je rebondi sur le sujet, je pense que des spécialistes passent par là, et je voulais savoir si il y avait une piste pour répondre à la question "comment installer SPIP sans toucher au safe_mode".

    Pour le moment j’ai créé un guide d’aide sur mon site pour expliquer "comment installer SPIP" et je conseille aux clients de nous demander, avant l’installation, la désactivation du safe_mode. Mais j’avoue que je préfèrerai pouvoir faire sans :)

    Si quelqu’un à une piste... merci par avance ;)

    A+
    Steve


  • Bonjour Steve,

    Le safe_mode sera absolète avec php bientôt.
    php.net/manual/fr/features.safe-mode.php

    squirrel


  • < #77 > pb accès espace privé : login interdit... ˆ
    par zouzi - 17 décembre 2011 20:31

    Steve, outre les éventuels problèmes de droits de fichiers/répertoire, le principal problème est dans le propriétaire des répertoires.
    Il faut que le propriétaire des répertoires contenant spip soit le même que l’utilisateur apache (par exemple www-data). Une fois cela fait, reste le problème du ftp, car l’utilisateur va poser ses fichiers via ftp avec comme propriétaire son propre compte, et non le www-data pris en exemple. Selon le serveur ftp utilisé, c’est cependant configurable.
    Cela évite de passer le safe_mode à off.


  • < #78 > pb accès espace privé : login interdit... ˆ
    par AlainW - 30 juin 2012 18:51

    Bonjour,

    Je viens d’essayer de migrer de SPIP 2.0.20 vers SPIP 3.0.2 en local avec EasyPHP, et j’ai aussi un problème de login. Mon mot de passe n’est pas reconnu. Que dois-je faire ? Impossible de me faire envoyer mon mot de passe, car je n’ai pas de serveur de mail en local.


  • < #79 > pb accès espace privé : login interdit... ˆ
    par fabius - 17 juillet 12:01

    i made a website using spip but nowdays my web is having a problems i’ve tried to logging but i got this error i made a research on the isue but what i found gives me another error
    <
    vérifier les droits d’écriture
    Le système a rencontré une erreur lors de l’écriture du fichier tmp/cache/xml/dir_test.php. Veuillez, en tant qu’administrateur du site, vérifier les droits d’écriture sur le répertoire ecrire/tmp/cache/xml.
    >

    i need help ? can anyone help me ?


  • Bonjour,

    il te faut certainement supprimer manuellement tout ce qu’il y a dans le fichier /temp/cache. Par ftp ou en local.

    Bon courage
    Chti47


  • Hi,

    as said by chti47, first drop with FTP everything is in the directory /tmp/cache.
    Then try again to connect.

    If not, check permissions on the directory /tmp/cache, they should be at 777


  • Je reçois tout à coup des messages de ce site, et quand j’essaie de me connecter avec l’adresse à laquelle je les reçois, il me dit que je suis inconnu sur le site. Merci de supprimer mon compte.


  •  


Répondre à la question

« pb accès espace privé : login interdit... »

Mots-clés

Vous pouvez étiqueter cette page de forum avec les mots-clés qui vous semblent les plus appropriés ; ils permettront aux prochains visiteurs du site de mieux se repérer :


Installation, mise à jour

Utilisation de l’espace privé

Administration, gestion, configuration du site

Créer ses squelettes

Qui êtes-vous ?