[ar] [ca] [cpf] [de] [en] [es] [fr] [it]

Ce forum d’entraide est recommandé pour les utilisateurs et utilisatrices occasionnels de SPIP (Système de publication pour l’Internet). Avant de poser une question, faites une recherche sur ce site, consultez les liens utiles. Si vous ne trouvez pas de réponse, postez votre message dans la rubrique appropriée, avec un titre explicite.

Sujets : 24110 Sujets résolus :  39 %

50 visiteurs en ce moment


Lenteur SPIP... la solution !

par Hervé - 7 mai 2007 10:23 - Réponse(s) : 11

Ceci n’est pas à proprement parler une question...plutôt la réponse à celle que je me posais. Ayant tout juste développé un site sous SPIP 1.9, j’étais ravi des fonctionnalités très évoluées de l’espace privé, en revanche grosse déception côté public...un site méga lent, très poussif, avec même parfois des erreurs 500...bouh, je pensais même abandonner SPIP ne pouvant raisonnablement pas livrer des sites à l’affichage si lent.

Mais après avoir parcouru ce forum, la réponse apparait par endroit, mais pas suffisament visible à mon goût tellement le sujet est sensible.

Donc, pour ma part, j’ai résolu le gros problème de lenteur que connaissait mon site en modifiant la valeur TRUE de la variable auto_compress en FALSE dans le fichier inc_version.php présent dans le dossier ecrire/ .
Ainsi avec la ligne
$auto_compress = false ;
vous devriez grandement accélérer la vitesse d’affichage et retrouver le sourire :-)

Mais à quoi donc sert cette compression des pages à la volée si c’est pour ralentir considérablement le site ?


  • #1 > Lenteur SPIP... la solution ! ˆ
    par Fil - 7 mai 2007 12:21

    Je suppose que ça dépend des hébergeurs ; en effet si c’est une cause de ralentissement il faudrait pouvoir le repérer — voire la désactiver — plus facilement.


  • < #2 > Lenteur SPIP... la solution ! ˆ
    par Fil - 7 mai 2007 12:23

    Il y a un ticket pour qu’on prenne en compte cette question un peu plus globalement ; merci d’indiquer les caractéristiques des hébergeurs chez qui "ça rame", et éventuellement d’y ouvrir des comptes de test ?

    http://trac.rezo.net/trac/spip/tick...

    Voir en ligne - ticket 909


  • < #3 > Lenteur SPIP... la solution ! ˆ
    par paolo - 7 mai 2007 23:36

    J’ai eu ce problème pendant un temps. La source du problème pour nous, je pense, n’était pas l’hébergement, mais le proxy (WinProxy) entre notre réseau local et l’internet. Lorsque nous avons changé de proxy, le problème a disparu.


  • < #4 > Lenteur SPIP... la solution ! ˆ
    par E.Roux - 22 juillet 2007 17:44

    Bonjour ! Ne sachant pas comment utiliser un ticket pour répondre et donner les informations. Je vous délivre mon expérience ici même.

    J’utilisais un hébergement 1&1 et spip ramait .... j’ai mis ca sur le compte de 1&1 .....
    Puis j’ai du transformer un vieux site html en site spip chez Amen ..... et ca s’est mis à ramer ....

    Ce n’était donc pas l’héberbeur mais bien spip.

    Le solution présentée ici marche à merveille chez ces deux hébergeurs !!!

    Merci !


  • < #5 > Lenteur SPIP... la solution ! ˆ
    par Voldor - 4 août 2007 18:46

    J’ai testé la solution car nous avons aussi des problèmes de lenteur, mais depuis, cela fait des buggs à toutes les redirections avec le message suivant :

    Warning : Cannot modify header information - headers already sent by (output started at /home/sites/site33/web/Om/mes_fonctions.php3:3) in /home/sites/site33/web/Om/ecrire/inc_version.php3 on line 1067

    Warning : Cannot modify header information - headers already sent by (output started at /home/sites/site33/web/Om/mes_fonctions.php3:3) in /home/sites/site33/web/Om/ecrire/inc_version.php3 on line 618

    J’ai donc remis "true" et les redirections remarchent...

    Serait-il possible d’avoir vitesse et redirections qui marchent ?

    Si quelqu’un a une idée ?

    Merci d’avance ;-)

    Le site : Les Baladins de la Tradition


  • Le message d’erreur indique qu’il y a des caractères émis par votre fichier personnel mes_fonctions, probablement une ligne blanche avant le < ? ou après le ?>.


  • < #7 > Lenteur SPIP... la solution ! ˆ
    par Voldor - 4 août 2007 21:01

    J’avais effectivement des lignes blanches avant <?

    Tout cela semble refonctionner parfaitement 
    !

    Mille mercis pour votre rapidité et votre efficacité !


  • < #8 > Lenteur SPIP... la solution ! ˆ
    par Xian - 28 novembre 2007 09:34

    Bonjour
    j’ai mis auto_compress en FALSE mais je n’ai pas remarqué d’amélioration de la vitesse du site spip qui reste lent.
    Y-a-t-il des reglages au niveau du cache qui peuvent être faits ?
    Mon site spip tourne sur xampplite qui contient APACHE, MYSQL, etc. Peut-être est-ce au niveau de APACHE qu’il y a quelque chose à faire ?


  • < #9 > Lenteur SPIP... la solution ! ˆ
    par Romanus - 6 mars 2008 12:27

    Xian essaie de mettre sur un vrai serveur


  • < #10 > Lenteur SPIP... la solution ! ˆ
    par Lauryn - 15 juin 2009 11:01

    Bonjour,

    Cette astuce est-elle valable pour Spip 2.0 ?


  • < #11 Lenteur SPIP... la solution ! ˆ
    par maxleo - 2 juin 2010 20:25

    Pour ma part, ça rame depuis que je suis passé de spip 2.0 à 2.1.


  •  


Répondre à la question

« Lenteur SPIP... la solution ! »

Mots-clés

Vous pouvez étiqueter cette page de forum avec les mots-clés qui vous semblent les plus appropriés ; ils permettront aux prochains visiteurs du site de mieux se repérer :


Installation, mise à jour

Utilisation de l’espace privé

Administration, gestion, configuration du site

Créer ses squelettes

Qui êtes-vous ?

  • Google Closure Compiler et test site mobile friendly

    par Didine
    16:39

    Pas de réponse

    Bonjour, Quelle est l’utilité de cocher Google Closure Compiler dans la compression de scripts ? Faut-il l’utiliser pour que Google considère le site comme mobike friendly ? Merci pour vos (...)

  • Compatibilité des notes de bas de page et URLs "Arbo"

    par erational
    13:33

    Résolu - Réponse(s) : 16

    un ticket pour suivre l’affaire https://core.spip.net/issues/3882

  • URL arborescentes simplifiées ?

    par erational
    12:19

    Résolu - Réponse(s) : 5

    voici un exemple pour des URLs arborescentes sans aucun préfixe Lignes à ajouter dans mes_options.php // urls arborescentes sans prefixes $GLOBALS['url_arbo_types'] = (...)

  • Recherche agenda avec prise de RDV en ligne

    par erational
    08:30

    Réponse(s) : 4

    Teste le plugin suggéréé par laetitia. Sinon essaie de contacter les pros à coté (Attention ce forum est juste un forum d’aide et pas une place de marché) Bonne (...)

  • Help ! Activer plugins par FTP ?

    par erational
    21 juillet 09:08

    Résolu - Réponse(s) : 11

    Merci pour le retour. Je passe en résolu alors.

  • formidable : mise en forme réponse

    par F Mattei
    19 juillet 15:52

    Pas de réponse

    Bonjour, je souhaiterais mettre en forme reponses_formulaires du plugin formidable en alignant les 3 premiers champs puis les 2 suivants ex prénom classe école du (...)

  • Htaccess rewriterules inefficaces

    par Z_spip
    18 juillet 23:47

    Résolu - Réponse(s) : 1

    Rebonsoir, Trouvé : une règle de réécriture en xxx.html entre en conflit avec les url propres si la rewriterule est donnée après celle des url propres, à savoir RewriteRule ^[^\.]+(\.html)?$ (...)

  • spip 3 et nivo slider : configurer les options

    par Jhessy
    18 juillet 12:08

    Résolu - Réponse(s) : 8

    Bonjour, SOS ! URGENT ! svp AIDEZ moi !!! les amis je voudrais savoir ci c’est possible d’avoir un lightBox avec le plugin nivo slider ? les seuls option/paramettres que je connais là sont : (...)

  • Impossible d'intégrer un document uploadé par FTP dépassant le _DOC_MAX_SIZE

    par SB
    17 juillet 12:53

    Réponse(s) : 1

    Bonjour, Pour compléter ma demande ci-dessus, pouvez-vous me dire si la variable _DOC_MAX_SIZE est sensée être prise en compte dans l’espace privé lorsque l’on souhaite attacher à un article / une (...)

  • Une page d'accueil juste pour la 1ère visite

    par Z_spip
    15 juillet 23:41

    Résolu - Réponse(s) : 3

    Bonsoir ! Bon... solution trouvée avec cookie "accueil" que je pose si je ne le trouve pas lors du chargement de sommaire (expiration à 30 jours). Tout visiteur qui revient dans l’intervalle de (...)

  • Messages : 29655
  • 8716 34 %
  • Poser une nouvelle question