5
Indiquez l’intérêt que vous portez à cette question
0

spip_loader : passer de version 3.1 à version 3.2

Bonjour,
ma question est simple :
comment passer de version 3.1 à version 3.2 avec spip_loader.php

spip_loader.php a bien mis à jour la version 3.1 vers la 3.1 la plus récente, mais comment faire pour passer à la version 3.2 ?

La version de spip_loader.php contient les lignes suivantes :

$grep -2e 3.2 spip_loader.php 
 * Branche installee par defaut.
 * 
 * Au choix parmi la liste des branches déclarées ('dev', '3.2', '3.1', ...)
 * @see lister_branches_proposees()
 */
if (!defined('_DEFAUT_BRANCHE_MAJ')) {
        define('_DEFAUT_BRANCHE_MAJ', '3.2');
}

--
                        'php' => '5.4.0',
                ),
                '3.2' => array(
                        'zip' => 'spip/stable/spip-3.2.zip',
                        'php' => '5.4.0',
                ),
--
 * - 2.5    : affichage de la version à installer, de la version déjà installée (si elle existe),
 * -          compatibilite PHP, loader obsolete
 * - 2.5.10 : on télécharge maintenant SPIP 3.2 
 * - 2.5.11 : coquille empechant des mises à jour
 * - 2.6.0  : déclaration simplifiée des branches / zips + sélecteur de branche

Je vois bien une condition (!defined(’_DEFAUT_BRANCHE_MAJ’) pour que spip_loader.php télécharge la version 3.2, mais comment forcer cette version ?

merci