2
Indiquez l’intérêt que vous portez à cette question
0

Impossible de désactiver des plugins après mise à jour vers spip 3.1.3

Bonjour,

J’ai mis à jour un site de développement de spip 3.0.22 vers 3.1.3. Pas de problème notable à signaler (et aucune message d’erreur) et le site fonctionne après la mise à jour, sauf (c’était attendu) une partie du site qui nécessite un plugin en cours de développement à l’aide de la Fabrique. Il fallait que je reconstruire le plugin en question pour spip 3.1.3, puisqu’il était indiqué comme compatible spip 3.0.22.

Sauf que la Fabrique n’était plus installé, et impossible de le réinstaller par le système de dépôt, puisqu’il n’apparaissait pas dans la liste des plugins proposés. Pas de problème, je l’installe à partir de son URL sur contrib.spip.net. C’est là que les ennuis commencent : le téléchargement et l’installation se font correctement (je vois le plugin apparaître dans plugins/auto/fabrique), mais impossible de l’activer. Aucun message d’erreur et rien dans les tmp/log/spip.log ou dans tmp/log/mysql.log, mais le plugin ne s’est pas activé. Si je tente de l’activer manuellement, ça ne fonctionne pas et le message d’erreur apparaît avant même que j’ai confirmé la demande de validation (je le vois en arrière-plan sous la boîte de dialogue).

J’ai donc voulu tester l’installation d’un autre plugin, qui lui s’est installé et activé correctement, sauf que (cette fois), je ne peux plus le désactiver. Même symptôme que décrit pour l’activation, sauf que c’est pour la désactivation.

Je suis bloqué à ce stade. Je n’ai rien dans les logs. J’ai tenté :
- vider tmp/ et cache/
- repartir de zéro en effaçant la table _plugins et en recréant les répertoires plugins et plugins/auto
- installer manuellement un plugin dans plugins (hors du répertoire plugins/auto donc) et l’activer après
- réparer la table

Les permissions des répertoires plugins et plugins/auto sont les mêmes que sur mes autres sites (755), ma base mysql va bien, et le site en lui-même ne bugge sur rien d’autre que sur cette histoire de plugins.

Désolé de la longueur du post, mais le problème est spécifique, il fallait donc des détails.

Merci d’avance pour le coup de main si quelqu’un-e a une idée !