26
Indiquez l’intérêt que vous portez à cette question
0

Relocalisation d’un site SPIP

Bonjour,

je suis nouveau dans le monde SPIP.
Je suis en train de récupérer un site SPIP (3.1.18) existant pour le porter ;
- d’abord sur mon PC Windows avec XAMPP
- sur Free.
Je ne suis pas l’auteur du site initial.
J’ai d’abord récupéré le site existant par Filezilla après avoir fait le dump de la base.
J’ai installé SPIP 3.1.8 sur mon PC.
J’ai copié les répertoires suivants sur mon PC :
- plugins
- IMG
- squelettes
- tmp (pour avoir le dump)
quand je me connecte comme administrateur, tout semble OK (après validation des plugins, rechargement de la base ...)
quand je passe en espace public, la page d’accueil se présente comme l’original mais quand je clique sur un des articles j’obtiens une page blanche (erreur 404, page non trouvée etc ...)
Pour je ne sais quelle raison, SPIP ne peut pas générer la page HTML
J’ai ensuite essayé le transfert chez FREE (avec PHP 5.6), d’abord en installant la version 3.0.26 (il semble que l’installation directe de 3.1 ne marche pas chez FREE), ceci sans recharger les données du site existant puis j’ai installé 3.1.18 puis rapatrié les répertoires lib, squelettes, IMG, plugins, rechargé le dump et comme sur mon PC localhost tout se passe bien en espace privé administrateur
et en espace public fonctionnement identique à mon PC local : page d’accueil OK, accès aux articles impossible (erreur 404 )
Ce problème est-il connu de quelqu’un de vous ?

Merci d’avance.

Jean-Yves