1
Indiquez l’intérêt que vous portez à cette question
0

Rubriques et Auteurs.. lien disparu ?

Bonjour
j’ai à nouveau un problème d’accès à l’auteur d’une rubrique.
La syntaxe suivante ne donnait plus le résultat escompté depuis quelques jours (j’utilise le plugin Macros de session étendue ) :

#_SESSION_SI{id_auteur,==,#ID_AUTEUR}
<INCLURE{fond=inclure/bandeau, id_rubrique, modifier=true}>
 
#_SESSION_SINON
<INCLURE{fond=inclure/bandeau, id_rubrique}>
 
#_SESSION_FIN

En cherchant un peu, je me suis aperçu que lorsque je crée une nouvelle rubrique, il n’y a plus de lien de créé avec l’auteur.
Vérification dans le contenu de la base : le lien n’est plus créé dans auteurs_liens. Les rubriques créées antérieurement sont présentes. Par contre, le lien rubrique/auteur a disparu de l’espace public.

Second souci, l’export de la base via spip bugue : export très long, et tables vides. Aucun souci détecté via PhpMyAdmin, et export effectué en quelques secondes, le temps de télécharger...

EDIT : j’ai depuis plusieurs mois une erreur lorsque j’essaie d’afficher le contenu de la table spip_rubriques dans l’espace privé :

erreur dans le squelette
critère inconnu agenda?
../tmp/cache/vertebres/table_spip_rubriques.html
boucle 1
ligne 2

Tout cela est sans doute lié.

Je soupçonne donc un souci au niveau de la gestion de la base par spip.

J’ai pour l’instant désinstallé puis réinstallé tous les plugins, vidé le cache, blacklisté mes_fonctions.php et mes_options.php sans succès.

Une idée ?
Merci
Phil