[ar] [ca] [cpf] [de] [en] [es] [fr] [it]

Ce forum d’entraide est recommandé pour les utilisateurs et utilisatrices occasionnels de SPIP (Système de publication pour l’Internet). Avant de poser une question, faites une recherche sur ce site, consultez les liens utiles. Si vous ne trouvez pas de réponse, postez votre message dans la rubrique appropriée, avec un titre explicite.

Sujets : 24136 Sujets résolus :  39 %

60 visiteurs en ce moment


Accueil > Forums de discussion >  Utilisation de l’espace privé > Mes plugins ont disparu - SPIP V3.0.16

Mes plugins ont disparu - SPIP V3.0.16

par Raphaël - 27 juin 13:22 - Réponse(s) : 5

Bonjour,

Je rencontre un problème extrêmement similaire à celui signalé sur ce post : je n’ai plus accès à liste de mes plugins depuis le backoffice qui sont pourtant présents et effectivement actifs.

Objectif : Effectuer la mise à jour vers SPIP 3.1.6 sur un hébergement dédié au développement, en vérifiant en amont la compatibilité des plugins, mais là de suite ça va être dur ! ^

Hébergeur : OVH - Performance - Mutualisé
Configuration principale de l’hébergement : PHP 7
SPIP : 3.0.16
Configuration du site (sous domaine) : ovhconfig PHP 5.6.30 + environnement developpement

Opérations globales effectuées avant apparition du défaut :

- Réactivation de l’hébergement de développement (inactif depuis neuf mois)
- Création d’une nouvelle base de données + import backup
- Mise à jour des documents (IMG)
- Mise à jour de la bdd avec celle du site en production (configuration SPIP à l’identique bien sûr)

J’ai à disposition une sauvegarde sqlite du site avant début des modifications : je ne touche plus à rien pour l’instant et me tourne vers vous en premier lieu.

Pour faire le parallèle avec le post de Jérémy :

J’ai vidé le cache, vérifié les droits sur répertoires plugins / auto et autres, supprimé / recréé le répertoire tmp + test d’installation d’un plugin manuellement... sans effet.

J’ai vérifié la memory_limit de PHP qui est à 512M.

Après activation des erreurs PHP dans mes_options.php, j’obtiens un "undefined_variable" dans le fichier /ecrire/req/mysql.php et plusieurs "undefined_index" référents aux "plugins-dist" et "plugins".

Need some help please !

L’url du site en développement est protégée par un htpwd : je me tiens prêt à vous transmettre les accès quand vous le voudrez et pourrez.

Merci d’avance / Cordialement,

Raphaël


  • #1 > Mes plugins ont disparu - SPIP V3.0.16 ˆ
    par Damien - 13 juillet 14:25

    J’ai peut-être une piste :
    j’ai supprimé le module "itwx_cimobile_3_3" du dossier des plugins/auto et les modules sont réapparus.

    Ce soucis doit venir d’une incompatibilité de certains modules avec la dernière version.


  • Bonjour,

    Merci bcp Damien pour ta piste (suppression des plugins pour tenter de trouver le petit méchant qui ne serait pas compatible) que je vais suivre par curiosité mais qui selon moi ne résout pas le pb dans le sens où le site en production est fonctionnel en l’état, et sans avoir effectué de mise à jour.

    N’ayant pas eu de réponse de la communauté, j’ai procédé à la mise en place d’une autre copie dudit site et après avoir répété les mêmes étapes, cette nouvelle copie est cette fois parfaitement fonctionnelle.

    Je trouvais et trouve intéressant que ce défaut puisse éventuellement servir d’analyse pour résolution dans le but 1/ de comprendre ce qui a pu se passer (car je ne suis pas un assez bon développeur pour le faire par moi-même) 2/ d’apporter les explications à d’autres qui rencontreraient un défaut similaire.

    J’espère que cette relance fera écho : je vais maintenir la version erronée encore quelques temps des fois que.

    Cordialement,

    Raphaël


  • < #3 > Mes plugins ont disparu - SPIP V3.0.16 ˆ
    par Damien - 13 juillet 17:18

    Raphaël,
    Ce soucis est vraiment bizarre. J’ai encore des problèmes d’affichage de la liste des plugins, mais il semble que c’est vraiment un problème de fond. J’ai activé le couteau suisse - Mise à jour automatique - et ai fait un certain nombre de mise à jour.
    ca ne marche pas complètement encore.


  • As-tu activé les erreurs php via le fichier mes_options.php et si oui quels sont les messages obtenus ?

    Sinon, et si tu ne l’as pas déjà fait, je te conseille de refaire une installation complète de SPIP dans la version que tu utilises, en faisant au préalable :

    - Un dump de ta base (SPIP + phpMyAdmin)
    - La sauvegarde des fichiers actuels, basculés dans un répertoire ’backup’ par exemple

    Tu vides ensuite ta base, tu réinstalles SPIP from scratch, tu rapatries ensuite ton dossier squelettes, tes plugins, ton fichier mes_options.php et tu réactives, pas à pas, ce qui te permettra peut-être de trouver le plugin coupable (en terminant par le plugin / thème que tu sembles suspecter itwx_cimobile).

    De là et si tout va bien, nouveau dump histoire de pouvoir au besoin revenir en arrière, tu vides la base et tu réimportes ton premier dump. Restera à voir quel sera le verdict ! Je pars du principe que tu interviens sur une version de test sur un "serveur de dev" :)

    J’ai obtenu une erreur et échec lors de l’import initial du backup via SPIP, mais pas en passant via phpMyAdmin.

    Après est-ce un problème "de fond" ... je ne sais pas, mais notre démarche est faite pour le savoir !

    A+


  • < #5 Mes plugins ont disparu - SPIP V3.0.16 ˆ
    par Christophe - 19 juillet 18:08

    Ouh là , même problème que moi :
    http://forum.spip.net/fr_267546.html#forum267550
    mais vous êtes bien plus câlés .

    Quand je vois la solution proposée , ça me paraît dément ! Il doit y avoir quelque chose qui cloche sur spip 3.1.6 et la gestion des plugins ...

    Je ne vois pas de réponse depuis le 13juillet , ça m’inquiète beaucoup ...




Répondre à la question

« Mes plugins ont disparu - SPIP V3.0.16 »

Mots-clés

Vous pouvez étiqueter cette page de forum avec les mots-clés qui vous semblent les plus appropriés ; ils permettront aux prochains visiteurs du site de mieux se repérer :


Installation, mise à jour

Utilisation de l’espace privé

Administration, gestion, configuration du site

Créer ses squelettes

Qui êtes-vous ?