[ar] [ca] [cpf] [de] [en] [es] [fr] [it]

Ce forum d’entraide est recommandé pour les utilisateurs et utilisatrices occasionnels de SPIP (Système de publication pour l’Internet). Avant de poser une question, faites une recherche sur ce site, consultez les liens utiles. Si vous ne trouvez pas de réponse, postez votre message dans la rubrique appropriée, avec un titre explicite.

Sujets : 24069 Sujets résolus :  39 %

62 visiteurs en ce moment


Accueil > Forums de discussion >  Utilisation de l’espace privé > Appel d'un formulaire avec paramètres dans un article

Appel d'un formulaire avec paramètres dans un article Résolu

par Nikko - 20 avril 19:34 - Réponse(s) : 1

Bonjour à tous,

Il est possible d’ajouter un formulaire dans un article ou une rubrique avec la syntaxe : <formulaire|mon_formulaire>
Ce qui correspond dans un squelette à : #FORMULAIRE_MON_FORMULAIRE

Dans le squelette, il est possible de passer des arguments à la balise comme définie dans http://programmer.spip.net/Passage-d-arguments-aux-fonctions

Savez-vous comment je peux faire pour passer des arguments à la syntaxe <formulaire|mon_formulaire> ?

Merci par avance pour votre réponse.


  • Avec les 3 fonctions définies comme si dessous :
    function formulaires_x_charger_dist($arg1, $arg2)
    function formulaires_x_verifier_dist($arg1, $arg2)
    function formulaires_x_traiter_dist($arg1, $arg2)

    Il suffit de faire :
    <formulaire|x|arg1=value1|arg2=value2> pour que cela fonctionne.
    Les valeurs value1, value2 seront passées à $arg1 et $arg2 pour les 3 fonctions ci-dessus.




Répondre à la question

« Appel d'un formulaire avec paramètres dans un article »

Mots-clés

Vous pouvez étiqueter cette page de forum avec les mots-clés qui vous semblent les plus appropriés ; ils permettront aux prochains visiteurs du site de mieux se repérer :


Installation, mise à jour

Utilisation de l’espace privé

Administration, gestion, configuration du site

Créer ses squelettes

Qui êtes-vous ?

  • Comment créer un portfolio de vidéos avec affichage mediabox ?

    par placido
    22 juin 20:23

    Réponse(s) : 4

    Ton message ne me laisse pas trop comprendre où le bât blesse. As-tu suivi ma solution avec le plugin Albums et le modèle surchargé ou parles-tu encore du l’inclure portfolio de base ? Pour ma (...)

  • Le menu déroulant des rubriques en sous rubriques a disparu

    par erational
    28 mai 18:12

    Réponse(s) : 4

    oh la la ton SPIP est très ancien SPIP 1.9.2b il faut absolument que quelqu’un le mette à jour. tu risques un piratage à tout moment. ps. PHP est langage de programmation. il permet de créer des (...)

  • squellette maparaam sous spip2.1.8

    par nora
    24 mai 20:51

    Réponse(s) : 27

    Bonsoir, je suis sous spip 2.1.8, avec un compte administrateur mais j’arrive pas à créer des comptes (auteurs) pour des utilisateur de notre site web sous spip. je peux modifier un compte qui (...)

  • Bug : identité site, adresse URL

    par b_b
    16 mai 20:12

    Réponse(s) : 5

    Comme tu peux le voir, les squelettes par défaut ajoutent ce slash final, tu n’as donc qu’à adapter tes squelettes persos pour en faire de même : https://zone.spip.org/trac/spip-zone/browser/_core_/plugin

  • Appel de logo dans l'édition d'un article sur l'espace privé

    par Lucie
    9 mai 18:16

    Résolu - Réponse(s) : 2

    En effet ! Merci ! Je ne m’étais pas penchée du côté des pulgins mais plutôt vers les modèles SPIP. Cela fonctionne parfaitement avec ce plugin. Je mets donc en résolu (...)

  • Copier un article

    5 mai 16:52

    Résolu - Réponse(s) : 4

    Pour donner une solution à ce problèm, on peut noter la présence de https://contrib.spip.net/Plugin-Duplicator

  • HTTP 302

    par Ajel
    30 avril 00:32

    Résolu - Réponse(s) : 52

    Pour moi j’ai eu le même message en installant spip 3.1, à l’étape 4. J’ai juste renommé htaccess.txt par .htaccess est le problème est résolu. Voilà si ça peut (...)

  • bug suite à restriction d'accès sur 'gestions des plugins'

    par Christophe Seguinot
    28 avril 16:19

    Pas de réponse

    Bonjour J’ai tenté de restreindre les accès des administrateurs à la configuration/’gestion des plugins’ de mon site. Soit en surchargeant la fonction autoriser_configurer_dist Soit en utilisant le (...)

  • erreur lors de l'ajout d'image

    28 avril 09:06

    Réponse(s) : 4

    Et mettre à php 7

  • Webmestre et administrateur restreint

    par Pierre KUHN
    27 avril 13:42

    Réponse(s) : 1

    Bonjour, Cela me semble logique, un webmaster a accès à tout le site, donc si tu le restreint c’est fini.

  • Messages : 9547
  • 2405 39 %
  • Poser une nouvelle question