[ar] [ca] [cpf] [de] [en] [es] [fr] [it]

Ce forum d’entraide est recommandé pour les utilisateurs et utilisatrices occasionnels de SPIP (Système de publication pour l’Internet). Avant de poser une question, faites une recherche sur ce site, consultez les liens utiles. Si vous ne trouvez pas de réponse, postez votre message dans la rubrique appropriée, avec un titre explicite.

Sujets : 24132 Sujets résolus :  39 %

50 visiteurs en ce moment


https sur l'espace privé

par mcsky2 - 9 mars 10:46 - Réponse(s) : 4

Bonjour,
J’utilise la version de spip 3.1.4 avec un proxy server et du https.
Seulement sur la page de maintenance (ecrire), certaines fonctionnalités restent en http. Par exemple "Vider le cache" reste en http et ca tourne en permanence. Pour écrire un article, il ne trouve pas les rubriques.
Par contre, si je vais dans Configuration -> Forum, les boutons sont bien en https.
J’ai mis un "RedirectMatch permanent ^/(.*)/ecrire/(.*)$ https://mondomaine:443/$1/ecrire/$2" dans 000-default.conf


  • J’ai l’impression qu’il s’agit d’un problème autre que de l’utilisation du langage php pour les deux cas cités en erreur.


  • J’ai fait une nouvelle installation de spip 3.1.4 et j’ai les même problèmes sauf que pour l’écriture d’un article, je peux sélectionner la rubrique.
    Sur ma version 3.1.4 en prod, la liste déroulante ne marche pas et le clic sur la loupe reste bloqué


  • J’ai essayé mes_options.php
    avec la variable

    1. $_SERVER['SERVER_PORT']='443';

    C’est pire
    J’ai les erreurs

    Bad Request

    Your browser sent a request that this server could not understand.
    Reason : You’re speaking plain HTTP to an SSL-enabled server port.
    Instead use the HTTPS scheme to access this URL, please.

    Ca réécrit les pages en :

    http://mondomaine:443

    Mais le serveur frontal n’y comprend plus rien.

    Peut etre que la solution est de faire du https sur l’apache ou se trouve les pages web ?
    Des idées ou des expériences similaires ?


  • < #4 https sur l'espace privé ˆ
    par b_b - 11 mars 12:33

    Salut, ta config semble un peu exotique, mais elle devrait être prise en charge par la branche 3.1. En effet, quelques patch on été appliqués suite à la discussion abordée dans ce ticket :

    https://core.spip.net/issues/3386

    Tu y trouveras peut-être l’info qu’il te manque.




Répondre à la question

« https sur l'espace privé »

Mots-clés

Vous pouvez étiqueter cette page de forum avec les mots-clés qui vous semblent les plus appropriés ; ils permettront aux prochains visiteurs du site de mieux se repérer :


Installation, mise à jour

Utilisation de l’espace privé

Administration, gestion, configuration du site

Créer ses squelettes

Qui êtes-vous ?