[ar] [ca] [cpf] [de] [en] [es] [fr] [it]

Ce forum d’entraide est recommandé pour les utilisateurs et utilisatrices occasionnels de SPIP (Système de publication pour l’Internet). Avant de poser une question, faites une recherche sur ce site, consultez les liens utiles. Si vous ne trouvez pas de réponse, postez votre message dans la rubrique appropriée, avec un titre explicite.

Sujets : 24009 Sujets résolus :  39 %

77 visiteurs en ce moment


Formulaire + upload image (site public) Résolu

par Pol - 3 juin 2014 20:34 - Réponse(s) : 5

Bonjour,

J’ai ajouté une fonctionnalité petites annonces à mon site (spip 3.0.5) : une nouvelle table + un formulaire CVT créé avec le plugin saisies, ça marche très bien. Maintenant, j’aimerais permettre aux gens d’ajouter une photographie. J’ai un peu de mal à trouver la bonne manière de m’y prendre... Est-ce usuel avec les formulaires CVT (il n’y a pas de tel exemple sur "programmer SPIP") ? Je connais l’existence de la balise #AJOUTER_DOCUMENT, mais il est clair je ne peux pas l’utiliser brutalement : il me faut modifier mon formulaire. Quant à décortiquer la manière dont #AJOUTER_DOCUMENT est fabriquée, je sens que je vais avoir un peu de mal et la migraine n’est pas loin...
Auriez-vous quelque piste ?
Merci d’avance !




Répondre à la question

« Formulaire + upload image (site public) »

Mots-clés

Vous pouvez étiqueter cette page de forum avec les mots-clés qui vous semblent les plus appropriés ; ils permettront aux prochains visiteurs du site de mieux se repérer :


Installation, mise à jour

Utilisation de l’espace privé

Administration, gestion, configuration du site

Créer ses squelettes

Qui êtes-vous ?

  • Backend & flux RSS problématique

    par Tania
    27 avril 18:46

    Résolu - Réponse(s) : 8

    Bonjour, Je me permets de relancer le sujet, car j’ai la même erreur qui me fait tourner en bourrique :) Erreur d'analyse XML : instruction de traitement XML ou texte pas au début d'une entité (...)

  • Maintenance de mon site

    par Serge Bonnery
    26 avril 11:22

    Pas de réponse

    Bonjour, j’ai confié à un professionnel la création, sous Spip, de mon site personnel lepervierincassable.net. Il se chargeait jusqu’à il y a peu de sa maintenance mais a cessé ses activités. Je (...)

  • question con : Comment aller simplement à la ligne

    par erational
    25 avril 19:23

    Résolu - Réponse(s) : 30

    je ferme ce fil

  • Simplification de l'espace privé

    par erational
    25 avril 19:14

    Réponse(s) : 1

    Un plugin permet d’alléger des options inutiles https://contrib.spip.net/LIM

  • Dates articles dans plan du site

    par Fa_b
    25 avril 11:34

    Réponse(s) : 10

    Je ne vois pas où est le problème, le dossier lang peut contenir différents fichiers provenant de différents plugins, et s’ils ont le même nom c’est qu’un plugin surchargeait déjà le fichier d’un autre (...)

  • Impossible d'importer ma base dans une install en localhost

    par Ajel
    23 avril 10:59

    Résolu - Réponse(s) : 18

    Merci Fa_b, C’est exactement ça ; Problème résolu. Bonne journée.

  • Site SPIP, quelle solution e-commerce ?

    par Fa_b
    21 avril 11:06

    Réponse(s) : 22

    Je n’ai pas utilisé le plugin livraison car j’ai un calcul de frais de port plus simple (une simple multiplication par produit), je passe par le plugin Coordonnées pour avoir une adresse de livraison (...)

  • Peut-on surcharger un fichier d'un plugin ?

    par SB
    20 avril 15:17

    Résolu - Réponse(s) : 2

    Bonjour, Merci pour votre réponse rapide et efficace. Je viens de tester et ... ça fonctionne ! Pour arriver à cela, j’ai surchargé les fichiers : /jwplayer/player/jwplayer.js que j’ai enregistré (...)

  • utf-8 base de donnée externe Mysql

    par Afronob
    20 avril 10:24

    Résolu - Réponse(s) : 4

    Dès la version 2.1.30 en fait. Attention avec SPIP 3.1 il faut modifier un peu cette recette, cf. https://core.spip.net/issues/3506

  • Impossible d'enresgistrer le nom du site

    par Uriel
    18 avril 15:08

    Résolu - Réponse(s) : 7

    Résolu pour ce problème, oui, merci pour votre article. J’ai en effet pu installer la version 3.0.25 (mais le .htaccess ne marchais pas, je l’ai pris sur un autre site). Bonne (...)

  • Messages : 29515
  • 8678 34 %
  • Poser une nouvelle question