[ar] [ca] [cpf] [de] [en] [es] [fr] [it]

Ce forum d’entraide est recommandé pour les utilisateurs et utilisatrices occasionnels de SPIP (Système de publication pour l’Internet). Avant de poser une question, faites une recherche sur ce site, consultez les liens utiles. Si vous ne trouvez pas de réponse, postez votre message dans la rubrique appropriée, avec un titre explicite.

Sujets : 24132 Sujets résolus :  39 %

63 visiteurs en ce moment


Probleme plugin social tags

par zoc_spaak - 27 janvier 2013 19:05 - Réponse(s) : 14

Bonjour à tous,

J’essaie sans succès d’installer ce plugin depuis plusieurs semaines, cependant rien ne s’affiche...
Pouvez précisez où il faut inclure le code car je suis un peu perdu...
J’ai essaye de le mettre dans article.html sous titres et dans head.html sous INSERT_HEAD mais rien n’y fait.

Je précise que je suis un peu (très) novice en la matière et que je suis sous spip 3.0.5 utilisant un squelette zpip.

Merci d’avance pour votre aide.
A bientôt


  • #1 > Probleme plugin social tags ˆ
    par Gilles - 27 janvier 2013 19:37

    Il faudrait poser la question sous la page de documentation du plugin : http://contrib.spip.net/Social-tags


  • < #2 > Probleme plugin social tags ˆ
    29 janvier 2013 13:11

    C’est déjà fait !
    J’ai posé la même question sur la page dédiée et pas de réponses...
    C’est pour ça que je suis venu ici !
    Pas d’idées ?


  • < #3 > Probleme plugin social tags ˆ
    par Gilles - 29 janvier 2013 13:30

    Je vais commencer par des question basiques :
    est-ce que le plugin est configuré ?
    Quel div va être transformée par le plugin pour y insérer les tags ?
    (par défaut la doc indique que c’est <div id="socialtags"></div>)
    Est-ce que cette div est bien présente dans le corps d’une page (par exemple après un article, ou dans content/page-sommaire.html) ?
    Est-ce que la console d’erreur de Firebug retourne des messages ?


  • < #4 > Probleme plugin social tags ˆ
    31 janvier 2013 12:23

    Le plugin est bien configuré.
    Je n’ai pas toucher par défaut au div et je ne comprends pas où je dois insérer ce div.
    Si je veux qu’il apparaisse apres le titre d’un article il faut que je le mette où ?
    Merci pour ton aide


  • < #5 > Probleme plugin social tags ˆ
    par zoc_spaak - 31 janvier 2013 13:18

    Mon div est inseré dans contenu/article.html
    comme cela :

    1. <div class="contenu-principal">
    2. <div class="cartouche">
    3. [(#LOGO_ARTICLE||image_reduire{200,200})]
    4. [<p class="#EDIT{surtitre} surtitre">(#SURTITRE)</p>]
    5. <h1 class="h1 #EDIT{titre}">#TITRE</h1>
    6. [<p class="#EDIT{soustitre} soustitre">(#SOUSTITRE)</p>]
    7. <!-- inclusion social tags -->
    8. <div id="socialtags"></div>
    9. <p class="info-publi"><abbr class="published" title="[(#DATE|date_iso)]">[(#DATE|nom_jour) ][(#DATE|affdate)]</abbr>[, <span class="auteurs"><:par_auteur:> (#LESAUTEURS)</span>]</p>
    10. [(#REM) Inclure le modele des liens de traductions ]
    11. #MODELE{article_traductions}
    12. </div>

    Télécharger

    Cela est bon ou non ?


  • < #6 > Probleme plugin social tags ˆ
    par H RECH - 12 octobre 2014 00:32

    J’ai eu des difficultés à activer le plugin Social Tags. Il a fallu modifier une ligne dans le fichier configurer_socialtags.html dans le répertoire prive/squelettes/contenu.

    1. [(#AUTORISER{configurer,socialtags}|oui)]

    Néanmois après avoir eu accès au panneau de configuration et paramétré les boutons que je souhaitais, rien ne s’est passé en matière d’affichage.
    J’ai tenté d’ajouter "le div socialtags" dans le fichier article de AHUNTZIC, (à la place indiquée) mais la seule chose qui apparaît dans l’article, c’est le code saisi.
    Merci de votre aide.
    HR


  • < #7 > Probleme plugin social tags ˆ
    par Guillaume Blanc - 6 février 2015 12:18

    Bonjour,

    J’ai le même problème, je suis sous spip 3.0.17 avec squelette ahuntsic, pas moyen d’afficher ces « tags » ; J’ai beau essayer de mettre <div id="socialtags"></div> un peu partout dans mon fichier squelettes/articles.html, rien ne s’affiche.

    J’avais déjà essayé avec spip 2.1, sans succès. Avec spip 3, pas mieux.


  • < #8 > Probleme plugin social tags ˆ
    par Henri31 - 6 février 2015 13:01

    Sur mon site ça fonctionne.
    J’ai paramétré Social Tags en insérant :
    #bloc-contenu .detail
    dans la fenêtre : "Insérer le bloc social-tags en-dessous du bloc suivant :"


  • < #9 > Probleme plugin social tags ˆ
    par Guillaume Blanc - 6 février 2015 15:04

    Merci. Ça fonctionne, enfin !

    J’ai donc enlevé le div ajouté manuellement dans article.html, et j’ai mis #bloc-contenu .detail dans la ligne prévue à cet effet dans la configuration du plugin. Sur le coup, ça n’a pas marché, et puis là, ça marche. J’ai l’impression que le "recalcul de la page" est aléatoire... Ou en tout cas, qu’il ne fonctionne pas toujours directement.


  • < #10 > Probleme plugin social tags ˆ
    par Henri31 - 6 février 2015 15:11

    Il ne faut pas oublier de vider le cache !


  • < #11 > Probleme plugin social tags ˆ
    par Frédéric - 22 mai 2015 14:38

    Bonjour,
    J’ai inséré moi aussi "#bloc-contenu .detail" dans le formulaire de config de SocialTags et ne rien ne s’affiche ! Faut-il ajouter du code dans la page ? Et si oui, savez-vous où ? (J’ai recalculé la page et vidé le cache à chaque fois)
    Merci
    FJ


  • < #12 > Probleme plugin social tags ˆ
    par jlgenet - 4 novembre 2015 23:32

    Bonjour
    J’ai le même pb avec scolaspip !Aucune des solutions ci-dessus ne fonctionnent !
    Par contre ça a fonctionné un jour ! Et ça fonctionne sur un site identique qui me servait de "brouillon" !
    Je suis sous spip 3.0.21


  • < #13 > Probleme plugin social tags ˆ
    par lael - 28 janvier 2016 16:10

    Chez moi sous Spip 3.1 et avec Escal, ça marche en mettant #contenu


  • < #14 Probleme plugin social tags ˆ
    par BOUDRY - 28 novembre 2016 21:42

    Sarkaspip 3 ou 4 #contenu ne fonctionne plus

    je suis passé à .page_article .cartouche:first... et là : cela RE fonctionne en SPIP 3.1.1 et 3.1.3


  •  


Répondre à la question

« Probleme plugin social tags »

Mots-clés

Vous pouvez étiqueter cette page de forum avec les mots-clés qui vous semblent les plus appropriés ; ils permettront aux prochains visiteurs du site de mieux se repérer :


Installation, mise à jour

Utilisation de l’espace privé

Administration, gestion, configuration du site

Créer ses squelettes

Qui êtes-vous ?