[ar] [ca] [cpf] [de] [en] [es] [fr] [it]

Ce forum d’entraide est recommandé pour les utilisateurs et utilisatrices occasionnels de SPIP (Système de publication pour l’Internet). Avant de poser une question, faites une recherche sur ce site, consultez les liens utiles. Si vous ne trouvez pas de réponse, postez votre message dans la rubrique appropriée, avec un titre explicite.

Sujets : 24136 Sujets résolus :  39 %

67 visiteurs en ce moment


Accueil > Forums de discussion >  Administration, gestion, configuration du site > Serveur surchargé avec des requêtes action=cron

Serveur surchargé avec des requêtes action=cron

par Stef - 17 octobre 2012 23:07 - Réponse(s) : 9

Mon hébergeur a suspendu mon compte car le serveur était surcharger par des requêtes. Entre autre, il y a une centaine de demande pour "action=cron" à quelques secondes d’intervalle. Ici un extrait du log apache :

[16/Oct/2012:00:42:47 -0400] "GET /spip.php ?action=cron HTTP/1.1" 204 776 "-" "-"
[16/Oct/2012:00:42:51 -0400] "GET /spip.php ?action=cron HTTP/1.1" 204 776 "-" "-"
[16/Oct/2012:00:42:57 -0400] "GET /spip.php ?action=cron HTTP/1.1" 204 776 "-" "-"

Est-ce un bogue avec SPIP ? J’ai la dernière version 3.0.5
Est-ce une tentative de spam/hack ?
Serait-ce que le .lock ne fonctionne pas ?

Quelqu’un pourrait m’aider ?


  • Même problème avec spip ?action=cron


  • < #2 > Serveur surchargé avec des requêtes action=cron ˆ
    par Stef - 22 octobre 2012 03:44

    Je viens de lire ceci dans la documentation du plugin SpeedSyndic :

    Si jamais ça ne marche pas au premier coup, c’est qu’il faut relancer #SPIP_CRON, en visitant simplement http://site.example.net/spip.php?action=cron.

    Pourtant, je n’ai jamais installé ce plugin sur mon site. Est-ce que Spip3 inclue des fonctions de Speedsyndic par défault ?

    Est-ce que des hackers pourraient tenter de faire boguer un serveur en envoyant à répétition des requêtes "action=cron" ?


  • Bonjour,

    J’ai aussi un grosse montée de requêtes MySQL depuis SPIP3 : @ Stef : as-tu résolu ce problème de ton côté ?

    Merci,
    françois


  • < #4 > Serveur surchargé avec des requêtes action=cron ˆ
    par Stef - 30 janvier 2013 06:49

    Oui, j’avais isolé le problème. Il venait du plugin Couteau suisse que j’avais installé sur mes sites (tant en local que chez mon hébergeur). Ce plugin faisait un appel trop souvent à la fonction action_cron() qui se trouve dans le fichier utils.php

    J’ai tenté de désactiver cette fonction sans succès, et personne ne pouvait m’aider. Alors j’ai été contraint à supprimer le plugin. Et plus aucun problème depuis.

    Est-ce que vous utilisez le Couteau suisse ?


  • Pour diminuer le nombre de requête en CRON :

    {{1./}} Dans configuration > contenus du site, désactiver la syndication automatique si celle-ci n'est pas utilisée. (Si elle est partiellement utilisée, praferer un boucle DATAS rss à une boucle ARTICLES_SYNDIQUE sur la page où elle est utilisée. )

    {{2./}} Dans configuration > fonctions avancées, désactiver les statistiques. (Préférer un compte Google Analytics qui ne réduira pas les performances de votre serveur.)

    {{3./}} Activer la lame "SPIP et le cache" du couteau suisse puis le configurer comme suit :
    - Utilisation du cache : cache permanent (bien que je ne suis pas sûr que ce critère soit réellement pris en compte)
    - Taille du cache : 100 Mo
    - Recalculer juste après une modification : non

    Si à ce stade, votre serveur est toujours surchargé, il faudrait créer un plugin qui permet de modifier le délais du CRON invalideur. Mais ça, je ne sais pas faire ( d'ailleurs, si quelqu'un peut aider, je suis preneur ).

  • < #6 > Serveur surchargé avec des requêtes action=cron ˆ
    par Charlie - 3 septembre 2013 12:48

    Bonjour,
    J’ai le même problème, je ne sais pas si c’est cela qui surcharge mon serveur mais j’ai des miliers de CRON qui n’aboutissent pas erreur 403.
    Mon site à des gros problèmes de lenteurs.


  • < #7 > Serveur surchargé avec des requêtes action=cron ˆ
    par Charlie - 4 septembre 2013 11:48

    J’ai dans mes logs, des milliers de requêtes provenant de mon propre serveur (mutu OVH) demandant /spip.php ?action=cron et aboutissant sur des erreurs 204


  • < #8 > Serveur surchargé avec des requêtes action=cron ˆ
    par Lonkarster - 22 octobre 2014 12:01

    Bonjour,

    J’ai le même type de problème.
    De 5 à 15 requêtes

    GET /spip.php?action=cron HTTP/1.1        403

    toutes les heures.
    Je n’ai pas le couteau Suisse.
    Je vais tenter de le configurer comme indiqué plus haut par Yohoo.
    *-Dans configuration>Contenus du site, je coche "Ne pas utiliser la syndication automatique"
    *-Dans configurations avancées>Statistiques des visites, je désactive les statistisques.
    *-Je n’ai pas le Couteau Suisse.
    *-J’ai repéré dans les tâches CRON du type maintenance ou invalideur, une drôle d’anomalie :
    Elle ressemble à ça :

    1. il y a 2 jours >monadresse@monnomdedomaine: [Le Nom de mon
    2. site]
    3. [forum]tPOXRerVztASeaOI | envoyer
    4. mail(monadresse@monnomdedomaine,[Le Nom de mon site]
    5. [forum] tPOXRerVztASeaOI,( ceci est un message automatique
    6. ) Message posté par horny à la suite de l'article "Le
    7. nom de
    8. l'article",http://Nomdemonsite.be/ecrire/?exec=controler_f
    9. orum&debut_id_forum=123 ** tPOXRerVztASeaOI ** I34Qyp
    10. http://www.QS3PESZGdxC9IoVKTAPT2DBYpPkMKqfz.com--
    11. http://www.QS3PESZGdxC9IoVKTAPT2DBYpPkMKqfz.com,,)
    12.  

    Télécharger

    Je l’ai supprimé mais je me demande d’où elle peut venir et ce qu’elle provoquait.

    Quelqu’un en sait-il plus concernant le fonctionnement de ces tâches planifiées qui encombrent la bande passante ?

    Merci de votre aide.


  • Pour ma part j’ai supprimé Couteau Suisse, tout n’est pas rentré dans l’ordre car je n’ai plus accès à la gestion de mes plugins..mais le site fonctionne en attendant la suite Car j’avais bien suivi démarche de Yohooo mais cela n’a pas fonctionné..


  •  


Répondre à la question

« Serveur surchargé avec des requêtes action=cron »

Mots-clés

Vous pouvez étiqueter cette page de forum avec les mots-clés qui vous semblent les plus appropriés ; ils permettront aux prochains visiteurs du site de mieux se repérer :


Installation, mise à jour

Utilisation de l’espace privé

Administration, gestion, configuration du site

Créer ses squelettes

Qui êtes-vous ?

  • Extréme lenteur de la version 3.0.2

    par Philyray
    05:36

    Résolu - Réponse(s) : 66

    Salut, Effectivement, quand j’ai vu sur le forum que c’était arrivé à plusieurs personnes en 2013, j’ai compris que ce n’était pas Escal. ° J’ai vidé le cache par ftp en supprimant partiellement le (...)

  • Pb indexation des images et robots.txt

    par erational
    04:28

    Réponse(s) : 10

    Guillaume, je vais sans doute intégrer ton principe sitemap dans un plugin pour que cela soit simple et rapide à déployer. En terme SEO, quelle est la meilleure option ? Proposer un 2ème sitemap (...)

  • Fichier backend obèse !

    par slave1802
    19 août 10:22

    Réponse(s) : 5

    Je l’ai désactivé après l’avoir testé et il l’est toujours. J’ai vidé le cache après bien sur.

  • Suppression rubrique

    par Philivert
    18 août 17:50

    Réponse(s) : 1

    Bonjour, pour supprimer une rubrique, il faut d’abord supprimer tout son contenu. Ensuite on peut la supprimer. Comment rendre accessible le site pour le public ??? Peux-tu préciser la question (...)

  • Afficher horaires d'ouverture magasin

    par Théo
    16 août 10:02

    Réponse(s) : 3

    Merci lotirim mais https://www.templatemonster.com/fr/ ne propose rien pour SPIP :( Ce que je souhaitais, c’est ce qui existe sur les Pages Jaunes, par exemple. Je vais tenter de trouver cela (...)

  • probleme de site changement de version php

    par albatros
    15 août 15:09

    Résolu - Réponse(s) : 1

    pb regle

  • Latex ne fonctionne plus

    par Fil
    13 août 22:28

    Résolu - Réponse(s) : 7

    merci de l’avoir signalé, j’ai changé de serveur en attendant que celui qui est planté redémarre

  • Site en travaux Attention : un problème technique (serveur SQL) empêche l'accès à cette partie du site. Merci de (...)

    par Roland
    13 août 12:57

    Résolu - Réponse(s) : 8

    J’ai parlé trop vite : Je n’avais fait qu’une seule tentative avec le "vieux fichier" ! Lors d’une deuxième consultation du site, le message est réapparu : cela ne vient donc pas nécessairement du (...)

  • Page blanche en site multilangue pour les pages en anglais

    par jeromeD
    11 août 23:11

    Pas de réponse

    Bonjour à tous, Je suis en train de configurer un site multilangue - français/anglais et je rencontre un soucis. J’ai choisi de définir la langue pour chaque rubrique et pour chaque article. Donc (...)

  • Accès à la gerstion des plugins impossible

    par umjean
    10 août 19:56

    Pas de réponse

    Bonjour Alors que les plugins sont bien installés, depuis le passage à la dernière version de spip, je n’ai plus accès à la gestion des plugins. Clt

  • Messages : 29689
  • 8724 34 %
  • Poser une nouvelle question