[ar] [ca] [cpf] [de] [en] [es] [fr] [it]

Ce forum d’entraide est recommandé pour les utilisateurs et utilisatrices occasionnels de SPIP (Système de publication pour l’Internet). Avant de poser une question, faites une recherche sur ce site, consultez les liens utiles. Si vous ne trouvez pas de réponse, postez votre message dans la rubrique appropriée, avec un titre explicite.

Sujets : 24136 Sujets résolus :  39 %

72 visiteurs en ce moment


Accueil > Forums de discussion >  Administration, gestion, configuration du site > Configuration des plugins impossible sous SPIP 2.1.2 [16017]

Configuration des plugins impossible sous SPIP 2.1.2 [16017] Résolu

par Alain BOURDEAU - 19 octobre 2010 16:52 - Réponse(s) : 13

Bonjour,

Sur une version fraichement upgradée en SPIP 2.1.2 [16017] ,
la configuration des plugins est impossible.
Je ne peux pas accéder à la configuration de TOUS les plugins installés précédemment ou fraichement.

J’ai systématiquement le même message

  1. erreur fichier configurer_{le_nom_du_plugin} introuvable

J’ai vérifié l’arborescence des plugins, elle est conforme à ce que est prévu et préconisé.

Que faire ?

Merci bien Alain BOURDEAU


  • (Fil déplacé d’« Utilisation de l’espace privé » vers « Administration, gestion... ».)

    Tous les plugins ne sont pas configurables, il se peut donc que ce message d’erreur soit sans objet.

    Quels sont les plugins installés ?
    Quels sont les plugins qui te renvoient ce message ?


  • < #2 > Configuration des plugins impossible sous SPIP 2.1.2 [16017] ˆ
    par Alain BOURDEAU - 19 octobre 2010 17:49

    Bonjour,

    la liste des plugins :

    1. 9 plugins activés.
    2.  
    3. *
    4. Activer le plugin
    5. Acces Restreint 3.0
    6. 0.3.0.2 - en développement
    7. Gestion de zones d’acces restreint.
    8. Configuration acces_restreint_3_0
    9. [Désinstaller]
    10. *
    11. Activer le plugin
    12. cfg : moteur de configuration
    13. 1.14.1 - stable
    14. Ce plugin permet de gérer très simplement des interfaces de (...)
    15. Configuration auto/cfg
    16. *
    17. Activer le plugin
    18. Compositions
    19. 0.9.1 - stable
    20. Ce plugin vous permet de définir plusieurs variantes de (...)
    21. Configuration compositions
    22. [Désinstaller]
    23. *
    24. Activer le plugin
    25. Interface d’administration des forums
    26. 0.1 - stable
    27. Interface d’administration des forums
    28. Configuration forum
    29. *
    30. Activer le plugin
    31. Menus
    32. 0.8 - en test
    33. Créez enfin vos menus dans la partie privée !
    34. Configuration menus
    35. [Désinstaller]
    36. *
    37. Activer le plugin
    38. Saisies pour formulaires
    39. 1.6.6 - en test
    40. Ce plugin permet de faciliter l’écriture de champs de formulaires (...)
    41. Configuration saisies
    42. *
    43. Activer le plugin
    44. SPIP Bonux 2.0
    45. 1.8.5 - stable
    46. Le plugin qui lave plus SPIP que SPIP, avec des chouettes cadeaux (...)
    47. Configuration auto/spip-bonux
    48. *
    49. Activer le plugin
    50. Squelettes Z pour SPIP (Zpip)
    51. 1.1.1 - stable
    52. Un jeu de squelettes comme squelettes-dist/ de SPIP, mais qui (...)
    53. Configuration zpip
    54. *
    55. Activer le plugin
    56. Zen-Garden
    57. 1.0.0 - en test
    58. Un jardin Zen pour Zpip
    59. Configuration zen-garden

    Télécharger

    Le site est hébergé chez ouvaton.

    A vous lire, Alain BOURDEAU


  • Mets à jour Config et Bonux, ça devrait aller mieux.


  • < #4 > Configuration des plugins impossible sous SPIP 2.1.2 [16017] ˆ
    par Alain BOURDEAU - 19 octobre 2010 19:00

    Merci, mais celà ne change rien. Même type de réponses.


  • Même après avoir vidé les caches ?


  • < #6 > Configuration des plugins impossible sous SPIP 2.1.2 [16017] ˆ
    par Alain BOURDEAU - 19 octobre 2010 23:24

    Sans changement même après cette manoeuvre de vidage du cache.

    Merci pour la sollicitude Alain BOURDEAU


    1. J’insiste, malgré tout : s’agit-il bien maintenant de CFG 1.15 et Spip-Bonux 2.2 au minimum ? Et de vidange des caches SPIP (suppression du contenu de /tmp à l’exception de /dump) ?
      A priori je ne vois que ces plugins susceptibles de générer ce type de « problème »...
    2. Tous les plugins sont-ils à jour ? Si non, mets-les à jour et vide les caches. Si oui, désactive-les un par un en finissant par Bonux et CFG.

    Cela dit ça ne devrait concerner que des plugins sans fonction de configuration, comme le plugin de gestion des forums par exemple. Peux-tu confirmer ?


  • < #8 > Configuration des plugins impossible sous SPIP 2.1.2 [16017] ˆ
    par Alain BOURDEAU - 20 octobre 2010 10:38

    Bonjour,
    J’ai testé la manip sur un autre site chez ouvaton et celà à marché.

    1. Effacement des plugins par FTP dans plugins et auto
    2. Vidage du cache avec obtention d'un lot de message d'erreurs due à la supression des plugins.
    3. Téléchargement de chaque plugin et activation dés son téléchargement suivi d'un vidage du cache

    Télécharger

    Sur le site en problème (syrafor.ouvaton.org), je teste la même démarche.

    La réinstallation par la procédure auto, a bien maché jusqu’à la tentative d’activation du plugin menus. La j’obtiens erreur 500. Aussi bien sur l’administration que sur le site (j’ai envoyé une question sur ce point à OUVATON).
    L’ordre de téléchargement et d’activation :

    1. cfg; spip bonux; accés restreint; squelette Z pour SPIP; menus

    En prévision :

    1. Zen garden; composition; interface d'administration des forums

    Voilà l’état du problème


  • Bonjour,

    par défaut le site doit être en php4.

    Pour ma part j’essaierai chez ouvaton AddHandler application/x-suexec-php5 .php dans le .htaccess afin de voir le site tourner en php5.

    Certain plugins préfèrent.


  • La manip proposée plus haut évoquait une simple désactivation des plugins un par un via le backoffice pour remonter à l’origine du problème.

    Je doute que le message d’erreur SPIP soit lié à la config serveur, contrairement à l’erreur 500.

    Ce sont deux problèmes distincts.


  • bonjour,

    Bien que d’accord avec @fred, l’err.500 arrive chez cet hébergeur, (comme chez d’autres, avec des configurations apache/mysql strictes en mutualisé).

    Cette erreur arrive aussi sur des sites sans bugs, de temps à autre, lors du recalcul de pages lourdes.


  • Oui, oui, l’erreur 500 n’est sans doute pas liée au problème précis dont il est question dans ce fil, à savoir l’accès aux fonctions de configuration de plugin.

    Puisque Alain dit avoir réglé ce problème par ailleurs en mettant ses plugins à jour, on peut peut-être considérer ce sujet comme résolu, non ?


  • < #13 Configuration des plugins impossible sous SPIP 2.1.2 [16017] ˆ
    par Alain BOURDEAU - 20 octobre 2010 12:09

    Oui,
    Merci a vous tous pour votre réactivité et vos connaissances.

    amicalement alin BOURDEAU




Répondre à la question

« Configuration des plugins impossible sous SPIP 2.1.2 [16017] »

Mots-clés

Vous pouvez étiqueter cette page de forum avec les mots-clés qui vous semblent les plus appropriés ; ils permettront aux prochains visiteurs du site de mieux se repérer :


Installation, mise à jour

Utilisation de l’espace privé

Administration, gestion, configuration du site

Créer ses squelettes

Qui êtes-vous ?

  • Extréme lenteur de la version 3.0.2

    par Philyray
    05:36

    Résolu - Réponse(s) : 66

    Salut, Effectivement, quand j’ai vu sur le forum que c’était arrivé à plusieurs personnes en 2013, j’ai compris que ce n’était pas Escal. ° J’ai vidé le cache par ftp en supprimant partiellement le (...)

  • Pb indexation des images et robots.txt

    par erational
    04:28

    Réponse(s) : 10

    Guillaume, je vais sans doute intégrer ton principe sitemap dans un plugin pour que cela soit simple et rapide à déployer. En terme SEO, quelle est la meilleure option ? Proposer un 2ème sitemap (...)

  • Fichier backend obèse !

    par slave1802
    19 août 10:22

    Réponse(s) : 5

    Je l’ai désactivé après l’avoir testé et il l’est toujours. J’ai vidé le cache après bien sur.

  • Suppression rubrique

    par Philivert
    18 août 17:50

    Réponse(s) : 1

    Bonjour, pour supprimer une rubrique, il faut d’abord supprimer tout son contenu. Ensuite on peut la supprimer. Comment rendre accessible le site pour le public ??? Peux-tu préciser la question (...)

  • Afficher horaires d'ouverture magasin

    par Théo
    16 août 10:02

    Réponse(s) : 3

    Merci lotirim mais https://www.templatemonster.com/fr/ ne propose rien pour SPIP :( Ce que je souhaitais, c’est ce qui existe sur les Pages Jaunes, par exemple. Je vais tenter de trouver cela (...)

  • probleme de site changement de version php

    par albatros
    15 août 15:09

    Résolu - Réponse(s) : 1

    pb regle

  • Latex ne fonctionne plus

    par Fil
    13 août 22:28

    Résolu - Réponse(s) : 7

    merci de l’avoir signalé, j’ai changé de serveur en attendant que celui qui est planté redémarre

  • Site en travaux Attention : un problème technique (serveur SQL) empêche l'accès à cette partie du site. Merci de (...)

    par Roland
    13 août 12:57

    Résolu - Réponse(s) : 8

    J’ai parlé trop vite : Je n’avais fait qu’une seule tentative avec le "vieux fichier" ! Lors d’une deuxième consultation du site, le message est réapparu : cela ne vient donc pas nécessairement du (...)

  • Page blanche en site multilangue pour les pages en anglais

    par jeromeD
    11 août 23:11

    Pas de réponse

    Bonjour à tous, Je suis en train de configurer un site multilangue - français/anglais et je rencontre un soucis. J’ai choisi de définir la langue pour chaque rubrique et pour chaque article. Donc (...)

  • Accès à la gerstion des plugins impossible

    par umjean
    10 août 19:56

    Pas de réponse

    Bonjour Alors que les plugins sont bien installés, depuis le passage à la dernière version de spip, je n’ai plus accès à la gestion des plugins. Clt

  • Messages : 29689
  • 8724 34 %
  • Poser une nouvelle question