[ar] [ca] [cpf] [de] [en] [es] [fr] [it]

Ce forum d’entraide est recommandé pour les utilisateurs et utilisatrices occasionnels de SPIP (Système de publication pour l’Internet). Avant de poser une question, faites une recherche sur ce site, consultez les liens utiles. Si vous ne trouvez pas de réponse, postez votre message dans la rubrique appropriée, avec un titre explicite.

Sujets : 23419 Sujets résolus :  39 %

79 visiteurs en ce moment


mise à jour Résolu

par J-Y - 25 juin 2010 14:37 - Réponse(s) : 10

Suite à la mise à jour de PHP5 sur un systeme linux OpenSuse, il a fallut procéder également à celle de SPIP 1.9.2 pour La dernière version SPIP 2.1.0. Celle ci a été effectuée suivant les recommandations de migration du site : spip.net/

Après mise à jour le message suivant apparait en tête de page :

Warning : strtotime() : It is not safe to rely on the system’s timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected ’Europe/Berlin’ for ’CEST/2.0/DST’ instead in /srv/www/htdocs/spip/ecrire/inc/auth.php on line 298 Warning : date() : It is not safe to rely on the system’s timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected ’Europe/Berlin’ for ’CEST/2.0/DST’ instead in /srv/www/htdocs/spip/ecrire/inc/auth.php on line 301 Warning : strtotime() : It is not safe to rely on the system’s timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected ’Europe/Berlin’ for ’CEST/2.0/DST’ instead in /srv/www/htdocs/spip/ecrire/inc/auth.php on line 303 Warning : date() : It is not safe to rely on the system’s timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected ’Europe/Berlin’ for ’CEST/2.0/DST’ instead in /srv/www/htdocs/spip/ecrire/inc/commencer_page.php on line 250

Comment peut on corriger le problème ?


  • #1 > mise à jour ˆ
    par Committo, Ergo Sum - 25 juin 2010 17:55

    C’est un Warning nouveau de PHP 5.3. Il faut mettre :

    date_default_timezone_set(’Europe/Paris’) ;

    dans mes_options.php.


  • < #2 > mise à jour ˆ
    par J-Y - 26 juin 2010 11:15

    Merci Committo pour la réponse mais je ne localise pas le fichier à modifier.


  • < #3 > mise à jour ˆ
    par fred - 26 juin 2010 13:58

    il se trouve dans le dossier config à la racine du site, sinon il faut le créer à cet endroit

    cf. http://www.spip.net/fr_article4654.html


  • < #4 > mise à jour ˆ
    par J-Y - 26 juin 2010 18:06

    Le fichier est bien pris en compte, merci Fred, mais j’ai toujours un message d’erreur :

    Warning : Division by zero in /srv/www/htdocs/spip/config/mes_options.php on line 2 Warning : date() : It is not safe to rely on the system’s timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected ’Europe/Berlin’ for ’CEST/2.0/DST’ instead in /srv/www/htdocs/spip/ecrire/public/parametrer.php on line 102 Warning : date() : It is not safe to rely on the system’s timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected ’Europe/Berlin’ for ’CEST/2.0/DST’ instead in /srv/www/htdocs/spip/ecrire/public/parametrer.php on line 107 Warning : date() : It is not safe to rely on the system’s timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected ’Europe/Berlin’ for ’CEST/2.0/DST’ instead in /srv/www/htdocs/spip/ecrire/inc/log.php on line 47


  • < #5 > mise à jour ˆ
    par Committo, Ergo Sum - 26 juin 2010 19:05

    Donne le contenu de ton fichier mes_options.php, visiblement l’ajout à faire n’a pas été fait correctement.


  • < #6 > mise à jour ˆ
    par J-Y - 26 juin 2010 19:37

    voila donc le contenu :

    1. <?php
    2. date_default_timezone_set(’Europe/Paris’);
    3. ?>

    Télécharger


  • < #7 > mise à jour ˆ
    par Committo, Ergo Sum - 26 juin 2010 23:03

    Le message parle d’une division par 0 ligne 2 dans le fichier /srv/www/htdocs/spip/config/mes_options.php
    et il n’y a pas de division dans le code que tu montres.
    Es-tu sûr que c’est bien ce message là qui apparaît pour ce fichier à cet endroit ?


  • < #8 > mise à jour ˆ
    par J-Y - 27 juin 2010 00:05

    Par le biais du copier coller que j’avais fait pour inserrer le code dans mon fichier j’introduisais également les mauvaises apostrophes. j’ai donc réécris la phrase suite à ta remarque Comitto et l’on voit la différence de couleur syntaxique ainsi que la forme des apostrophes dans le nouveau code.

    Après correction dans le fichier il n’y a plus de message d’erreur.

    Merci Comitto et Fred pour votre aide, le problème est donc résolu.


  • < #9 > mise à jour ˆ
    par hamani - 16 novembre 2012 13:32

    Bonjour à tous, voila mon nouveau problème :

    Fatal error : Cannot redeclare echapper_php_callback() (previously declared in /var/www/vhosts/rodaddhd.org/httpdocs/ecrire/public/parametrer.php:63) in /var/www/vhosts/rodaddhd.org/httpdocs/ecrire/public/sandbox.php on line 159

    Merci d’avance de votre aide


  • < #10 mise à jour ˆ
    par CLEMENT - 30 novembre 2012 17:00

    bonjour

    mon hébergeur vient de passer en PHP 5.4

    je suis en SPIP 2.1.19

    depuis j’ai ce message :

    Warning : Illegal string offset ’id_auteur’ in /homepages/10/d220045033/htdocs/sixfours/ecrire/public/assembler.php(610) : eval()’d code on line 2

    j’ai bien créé un fichier sous /config mes_options.php

    dans le quel je mets :

    <?php
          date_default_timezone_set
    ('Europe/Paris');  
        
    ?>

    merci de m’aider à résoudre ce problème




Répondre à la question

« mise à jour »

Mots-clés

Vous pouvez étiqueter cette page de forum avec les mots-clés qui vous semblent les plus appropriés ; ils permettront aux prochains visiteurs du site de mieux se repérer :


Installation, mise à jour

Utilisation de l’espace privé

Administration, gestion, configuration du site

Créer ses squelettes

Qui êtes-vous ?

  • Page blanche

    par erational
    11:23

    Réponse(s) : 21

    la sauvegarde sert uniquement en cas de pépin mais en général spip fait tout le boulot tout seul. lire : http://contrib.spip.net/Mise-a-jour-1-9-x-vers-2-0-x (...)

  • serveur apache sous windows 10 64 bits

    par Philivert
    10 février 17:33

    Réponse(s) : 1

    Bonjour, Personnellement j’utilise le serveur Laragon, plus simple à mon goût que Wampserveur par exemple. Tu l’installes, tu copies le répertoire spip dans le répertoire www de Laragon et tu accèdes (...)

  • (Re)Construction d'un site web

    par Fridolin
    8 février 16:37

    Pas de réponse

    Bonjour, Je vous écris pour vous demander si ce CMS offrira les fonctionnalités nécessaires pour répondre aux besoins de mon projet ; tout autre conseil ou avis sera le bienvenu. J’ai dernièrement (...)

  • Le plugin formidable ne crée pas les tables

    par erational
    8 février 08:28

    Réponse(s) : 1

    Commence par désinstaller et réinstaller le plugin. Normalement il devrait créer les tables SQL sans problème.

  • Installer Spip3 sous WAMP

    par jean-pierre45650
    7 février 18:41

    Réponse(s) : 8

    bonjour, je n’arrive pas à installer sip en local avec wamp ou puis-je trouver un logiciel clairement expliqué pour le faire. Merci

  • SPIP 3.1 et le padding

    par gaston
    7 février 14:39

    Réponse(s) : 3

    Je retire ce que j’ai dit, j’avais un site en 3.0 non responsive, et j’avais aussi le soucis avec mes paddings. Donc seul mes sites en 2.1 passés en 3.1 n’ont pas de problème, et tout est dans (...)

  • migration spip 3.0.20 à 3.1.0

    par mcsky2
    5 février 15:03

    Résolu - Réponse(s) : 2

    Merci pour l’aide. J’ai choisi de modifier le fichier svn10000.php Je n’ai , a priori pas, supprimé de dossier cache_gd2. J’ai fait une autre installation de spip 3.1 et il n’y a pas non plus de (...)

  • Directory Listing Denied

    par Gilles
    5 février 01:03

    Résolu - Réponse(s) : 6

    Il est tout à fait possible d’installer SPIP sur IIS, mais la manipulation n’est pas simple. Il faut juste affecter manuellement les droits d’écriture pour config, tmp, IMG et local C (...)

  • Pluging Masonry et SPIP 3.1

    par gaston
    4 février 01:41

    Pas de réponse

    Bonjour, Voila j’utilise le plugings Masonry sur spip 3.0, avec spip 3.1, j’aimerai migrer tout mes sites là-dessus, mais ce pluging n’est pas à jour pour 3.1. C’est assez problématique dans la (...)

  • je ne peux pas configurer le plug-in Social Tags

    par Marie-Claude
    2 février 22:53

    Résolu - Réponse(s) : 4

    Bonsoir J’ai résolu ce problème qui était resté en suspens depuis mai dernier ! par hasard, en travaillant sur un autre chose, j’ai été amenée à télécharger les plugins jquery_ui_spip2 ; csg, spip-bonux (...)

  • Messages : 18853
  • 4641 43 %
  • Poser une nouvelle question