[ar] [ca] [cpf] [de] [en] [es] [fr] [it]

Ce forum d’entraide est recommandé pour les utilisateurs et utilisatrices occasionnels de SPIP (Système de publication pour l’Internet). Avant de poser une question, faites une recherche sur ce site, consultez les liens utiles. Si vous ne trouvez pas de réponse, postez votre message dans la rubrique appropriée, avec un titre explicite.

Sujets : 24076 Sujets résolus :  39 %

46 visiteurs en ce moment


Accueil > Forums de discussion >  Création de squelettes > Aucun squelette 'syndic.html' n'est disponible...

Aucun squelette 'syndic.html' n'est disponible...

par geopos - 25 avril 2009 12:33 - Réponse(s) : 5

Bonjour,

Novice, je développe sans modifier ni créer les squelettes, me focalisant sur le fond plutôt que sur la forme du site. La question est peut être triviale pour les spécialistes, la voici :

Dans "Les sites référencés dans cette rubrique" je n’obtenais apparemment pas d’erreur au premier site référencé. Après le deuxième, voici l’erreur 404 obtenu :

L’option "Pas de syndication" est activée pouratant.

Une idée pour créer ce squelette ?
Merci.

NB : Message déjà posté mais je ne le vois pas.

SPIP 2.0.7 [13888]


  • J’ai trouvé ceci, UN BUG DEJA REPARE QUI SUBSISTE DANS DANS LA 2.0.7.

    Est ce la solution ?

    http://article.gmane.org/gmane.comp.web.spip.user/143217

    QUOTE

    Bonsoir,

    J’ai eu aussi le même souci, apparemment il s’agit d’un bug qui aurait déjà
    était réparé dans de précédentes versions de Spip, mais qui dans la 2.0.7 est
    remis avec l’erreur.

    Il s’agit en effet de retoucher 2 fichiers dans ecrire/urls/
    à savoir : page.php et html.php

    avec les modifications suivantes :

    spip/ecrire/urls/html.php (ligne 78)
    spip/ecrire/urls/page.php (ligne 73)

    remplacer : $contexte = array($_id => $id_objet) ;

    par : $contexte[$_id] = $id_objet ;
    if ($type == ’syndic’) $type = ’site’ ;

    Vous n’aurez plus qu’à uploader les nouveaux fichiers corrigés et hop plus
    d’erreur !

    @+

    UNQUOTE


  • < #2 > Aucun squelette 'syndic.html' n'est disponible...  ˆ
    par superyms - 27 avril 2009 11:26

    bonjour,

    je te confirmes que c’est la bonne solution à ton problème qui était aussi le mien ! (depuis la correction tout est parfait !)

    j’ai fourni cette réponse sur la liste des utilisateurs et j’espère que ceux qui ont ce problème pourrons ainsi le solutionner.

    ciao


  • Bonjour
    mon problème s’apparente un peu au votre mais j’utilise spip 2.0.9 et mon message d’erreur est plutôt le suivant : Aucun squelette ’saisies/select_mots.html’ n’est disponible...
    en plus pour les modifications que vous suggérez c’est ce qu’il y a déjà dans les fichiers à retoucher

    NB : j’essaie d’utiliser un formulaire de recherche multi-criteres dont voici le code :

    <B_groupe>
            [(#ENV{message_ok}|oui)<INCLURE{fond=formulaires/pluri_criteres-resultats}{id_groupe=#ENV{message_ok}}{resultat_bref}>]
            <div class="formulaire_spip">
            <form method="post" action="#ENV{action}">
            #ACTION_FORMULAIRE{#ENV{action}}
           
            [(#ENV{resultat_bref}|oui) <input type="hidden" name="resultat_bref" value="oui"/>]
            [<ul class="erreur">        <li class="erreur">
            <span class="erreur_message">(#ENV{message_erreur})</span>
            </li>
            </ul>
            ]
           
            <ul>
           
            <BOUCLE_groupe(GROUPES_MOTS){par num titre}>
           
           
           
                <li><INCLURE{fond=saisies/select_mots}{id_groupe}{titre}{id_mot=#ENV{message_ok}|table_valeur{#ID_GROUPE}}></li>
            </BOUCLE_groupe>
            </ul>
                <input type="submit" value="<:ok:>" />        </form>
            </div>
            </B_groupe>

  • bonjour j’ai aussi un probleme avec la version 3 de spip je voudrait creer un formulaire en html mais a chaque fois que jessaye dapler ma page formulaire.html il mafiche toujours un message d’erreur car j’ai creer mon formulaire sans utiliser le codage avec le language spip est ce la le probleme

    Aucun squelette fond=formulaire/inscription.html n’est disponible...
    message important à l’aide


  • Bonjour,

    C’est hors-sujet je crois, mais je t’invite quand même à te renseigner sur le plugin formidable qui fabrique des formulaires tout comme il faut :
    http://contrib.spip.net/Formidable-le-generateur-de-formulaires




Répondre à la question

« Aucun squelette 'syndic.html' n'est disponible...  »

Mots-clés

Vous pouvez étiqueter cette page de forum avec les mots-clés qui vous semblent les plus appropriés ; ils permettront aux prochains visiteurs du site de mieux se repérer :


Installation, mise à jour

Utilisation de l’espace privé

Administration, gestion, configuration du site

Créer ses squelettes

Qui êtes-vous ?

  • SPIP ecommerce

    par lotirim
    20:12

    Résolu - Réponse(s) : 7

    Bonjour, je ne suis pas treees forte en programmation, hélas, mais j’espère comprendre votre demande correctement, et donc, voilà un lien vers le site que j’aime (...)

  • Exécution de #SET dans une boucle

    par Z_spip
    26 juin 23:22

    Réponse(s) : 3

    Bonsoir bonsoir, Si ça pet aider à comprendre le souci, mes essais sont là : http://www.routedesstages.lautre.net/cn/spip.php?rubrique3 La couleur de la puce et de la flèche "lire la suite" de (...)

  • fichier langue et code html

    par placido
    26 juin 15:24

    Résolu - Réponse(s) : 4

    Les fichiers de langue se trouvent dans un dossier lang/ dans les différents répertoires qui composent le chemin (path) de SPIP. Lire cette documentation et les pages suivantes pour plus (...)

  • inclure du PHP dans un squelette qui fonctionne sans recalcul de la page

    par philippe
    25 juin 23:59

    Pas de réponse

    Bonjour Sur le site que je programme, les futurs rédacteurs ont la possibilité de changer les arrière-plans CSS en chargeant des images. J’ai fait une fonction php stockée dans mes_fonctions.php qui (...)

  • #TITRE + du texte en dur

    par Chrys
    25 juin 16:21

    Résolu - Réponse(s) : 2

    Merci Fa_b, j’ai opté pour ta seconde proposition. Elle fonctionne très bien, et c’est une condition que je trouve plus simple a lire. Merci

  • Récupérer toutes les valeurs d'un champ select multiple CVT dans un array

    par orava
    24 juin 12:02

    Résolu - Réponse(s) : 1

    Okay je me sens bête (on va mettre ça sur le compte de la canicule qui a frit mon cerveau) Bref je mets la soluce là pour ceux que ça intéresse, il suffisait tout bêtement de rajouter des crochets à (...)

  • Problème de sitemap avec SPIP 3

    par benolaos
    23 juin 07:33

    Résolu - Réponse(s) : 22

    Il semble que finalement le sitemap.xml fonctionne, mais ne s’affiche pas comme avant (peut-être dû à une feuille de style...). Désolé pour le bruit.

  • pb spip/spipr et test robots google

    par Didine
    22 juin 10:50

    Résolu - Réponse(s) : 6

    J’ai testé une première fois et j’ai vidé le cache de spip et ça fonctionne maintenant :) Merci beaucoup pour ton aide.

  • boucle DATA et filtrage avec un critère optionnel

    21 juin 17:48

    Pas de réponse

    Bonjour, je tente d’afficher des données récupérées avec la boucle data. J’aimerais utiliser le filtrage avec un critère optionnel passé en paramètre comme ceci par exemple : <BOUCLE_exemple(DATA) (...)

  • Rubriques

    18 juin 08:26

    Réponse(s) : 4

    Bonjour, J’ai mis du temps à te répondre j’ai fais plusieurs essais et je n’y arrive pas, pour les patronymes c’est bon j’utilise une sous rubrique dans la rubrique "généalogie" mais pour un article (...)

  • Messages : 29283
  • 8190 43 %
  • Poser une nouvelle question