[ar] [ca] [cpf] [de] [en] [es] [fr] [it]

Ce forum d’entraide est recommandé pour les utilisateurs et utilisatrices occasionnels de SPIP (Système de publication pour l’Internet). Avant de poser une question, faites une recherche sur ce site, consultez les liens utiles. Si vous ne trouvez pas de réponse, postez votre message dans la rubrique appropriée, avec un titre explicite.

Sujets : 24048 Sujets résolus :  39 %

42 visiteurs en ce moment


Accueil > Forums de discussion >  Installation, mise-à-jour > Mise a jour de 1.9.2.e vers 2.02 : Error(s) in template

Mise a jour de 1.9.2.e vers 2.02 : Error(s) in template Résolu

par noobissima - 9 janvier 2009 16:15 - Réponse(s) : 7

Bonjour,

Les nouveautés de SPIP v2 sont alléchante et j’ai donc décidé de faire la mise à jour de mon site web qui tourne sous SPIP 1.9.2.e vers la version 2.0.2

J’ai renommé les répertoires plugins et squelettes ; et vider mon cache.
J’ai ensuite décompresser la version 2.0.2 sur mes anciens fichiers.
Puis lorsque je vais a la page d’admin de mon site, je tombe sur :

Technical message :
the upgrade procedure should be ran to adapt the database to the new version of SPIP.

Il y a néanmoins un problème lors de la mise à jour de la base de données :

SPIP 2.0.2 debug Noobissima
Error(s) in template

1          SQL error
@@character_set_connection AS n
Unknown system variable 'character_set_connection'
 HELP        
2          SQL error
@@character_set_connection AS n
Unknown system variable 'character_set_connection'
 HELP        
3          SQL error
@@character_set_connection AS n
Unknown system variable 'character_set_connection'
 HELP        
4          SQL error
@@character_set_connection AS n
Unknown system variable 'character_set_connection'
 HELP        
5          SQL error
@@character_set_connection AS n
Unknown system variable 'character_set_connection'
 HELP

D’où provient l’erreur ?

J’ai cru comprendre que c’est un problème d’encodage de ma base de données. Il faudrait la convertir en utf8. Cependant je tourne sur Mysql 4.0 et je ne connais pas le moyen d’effectuer cette manipulation.


  • J’ai le même problème en passant de la version 1.9.2d à 2.0.8, mon jeu de caractère est ISO 8859-1.

    Voici le message d’erreur

    Erreur(s) dans le squelette

    1 Erreur MySQL
    @@character_set_connection AS n
    Unknown system variable ’character_set_connection’

    2 Erreur MySQL
    @@character_set_connection AS n
    Unknown system variable ’character_set_connection’

    3 Erreur MySQL
    @@character_set_connection AS n
    Unknown system variable ’character_set_connection’

    4 Erreur MySQL
    @@character_set_connection AS n
    Unknown system variable ’character_set_connection’

    5 Erreur MySQL
    @@character_set_connection AS n
    Unknown system variable ’character_set_connection’


  • En continuant à fouiller j’ai trouvé ce lien http://forum.spip.org/fr_211773.html.

    Le problème est les plugins. J’ai changé le nom de mon dossier "plugins" pour "plugin" (pas de "s") et j’ai pu faire la migration.


  • Salut,

    Je confirme que ce problème fut le cas pour une MAJ d’un spip 1.9.2h vers 2.0.8

    J’ai renommer plugins en plugin est la MAJ a put s’effectuer !

    Cependant, une fois tous bien MAJer ! j’ai remis plugin en plugins.

    A sa fonctionne correctement !

    Est ce un bug ? Ou une manipulation à effectuer sur les tables de la base de donnée ?

    squirrel :D


  • < #4 > Mise a jour de 1.9.2.e vers 2.02 : Error(s) in template ˆ
    par Snowcat - 17 novembre 2009 17:55

    Bonsoir à tous !

    Une autre solution est de se déconnecter puis de se reconnecter ! Je l’ai fais une fois et ça à directement marché

    (je passais d’une 1.9.2d à une 2.0.10)

    Solution trouvée sur Democrite

    Bonne soirée à tous !


  • Bonjour, moi je suis en train de passer de 1.9.2b en 2.10 en suivant la procédure http://www.spip.net/fr_article4121.html

    donc partant d’un répertoire ou il n’ ya QUE /IMG /config plus l’archive spip 2.10 décompactée, je n’ai AUCUN répertoire plugin au moment de la mise à jour dans l’interface privée et j’ai quand même l’erreur.


  • voui... ce message d’erreur s’affiche parfois (!?).

    relancer la mise à jour (reclic sur le lien) suffit généralement à l’éliminer.


  • Bon effectivement à force d’insister cà passe. grosse frayeur quand même. J’avais pourtant fais toute la procédure en local avant.


  •  


Répondre à la question

« Mise a jour de 1.9.2.e vers 2.02: Error(s) in template »

Mots-clés

Vous pouvez étiqueter cette page de forum avec les mots-clés qui vous semblent les plus appropriés ; ils permettront aux prochains visiteurs du site de mieux se repérer :


Installation, mise à jour

Utilisation de l’espace privé

Administration, gestion, configuration du site

Créer ses squelettes

Qui êtes-vous ?

  • Le formulaire d'insciption ne s'affiche pas

    par cyrille
    18 mai 17:29

    Pas de réponse

    Le site est sous SPIP 3.1.4 [23444] + écran de sécurité 1.3.0 Le formulaire d’inscription appelé par la balise #FORMULAIRE_INSCRIPTION présente sur la page (...)

  • Restauration de base de donnée mise à jours 1.9.2c vers 3.1.3

    par Nako
    18 mai 14:52

    Pas de réponse

    Bonjour, je souhaite souhaite mettre à jour mon site spip 1.9.2c vers une version plus récente. Seulement lorsque je tente de restaurer ma base de données via l’outil de restauration de l’interface (...)

  • Perte calendrier suite à mise à jour

    par adil
    16 mai 12:48

    Résolu - Réponse(s) : 1

    En passants tous les éléments de maintenance (et en cliquant un peu partout) c’est revenu. Merci quand même.

  • Probleme d'affichage suite maj sarka 3.2 vers 3.4

    par cfalanoue
    12 mai 12:55

    Pas de réponse

    Bonjour, Mon site est en SPIP 3.0.10 et SARKA 3.4. Depuis la maj, les pages sommaire, article, rubrique ne prennent plus en chargent le css rentré dans la configuration de SARKA. (...)

  • Message d'erreur

    par BRNRD
    12 mai 08:59

    Réponse(s) : 2

    J’ai finalement téléchargé une version antérieure de Spip

  • Spip Contrib et Spip Rezo

    par Lucie
    12 mai 02:48

    Résolu - Réponse(s) : 4

    Merci beaucoup Suske ! Vous avez su pointer le problème... grâce à vous je peux désormais poser mes questions relatives aux plugins sur la liste rezo comme il se (...)

  • Problème d'affichage de puce après mise à jour vers spip 3.1

    par Suske
    11 mai 15:33

    Réponse(s) : 1

    Est-ce OK dans le privé mais pas dans le public ? SI oui, c’est qu’il y a quelque chose qui pouiche dans le squelette, probablement. D’autres pistes pour affiner : faites un test sans squelette (...)

  • Page blanche suite à mise à jour 2.1.8 vers 3.1

    par Suske
    6 mai 13:04

    Réponse(s) : 2

    Hello pour passer de la v.2 à la v.3, la procédure est décrite ici http://www.spip.net/fr_article5693.html. Le mieux est de repartir d’une sauvegarde. Il y a aussi un article sur la migration des (...)

  • Reprise et création sous SPIP d'un site littéraire

    par fernandes
    4 mai 15:02

    Pas de réponse

    Construction d’un site internet Objectif : refonte dans un même squelette le contenu du site bdtresor.net (wordpress) et du site livredumonde.fr (spip) avec en plus des nouveautés. Le site doit (...)

  • SpipService plugin

    par erational
    3 mai 19:08

    Réponse(s) : 1

    dans le paquet xml, modifie les bornes de compatibilité en indiquant SPIP 3.1 ensuite voici un article expliquant les points à vérifier pour passer un plugin en SPIP 3.1 (...)

  • Messages : 19524
  • 4772 43 %
  • Poser une nouvelle question