[ar] [ca] [cpf] [de] [en] [es] [fr] [it]

Ce forum d’entraide est recommandé pour les utilisateurs et utilisatrices occasionnels de SPIP (Système de publication pour l’Internet). Avant de poser une question, faites une recherche sur ce site, consultez les liens utiles. Si vous ne trouvez pas de réponse, postez votre message dans la rubrique appropriée, avec un titre explicite.

Sujets : 24073 Sujets résolus :  39 %

71 visiteurs en ce moment


Problème plugin Boutons Texte Résolu

par diego - 10 septembre 2008 12:07 - Réponse(s) : 15

Bonjour,

J’ai installé sur mon site SPIP le plugin Boutons Texte qui permet d’agrandir ou réduire la taille du texte de la page.

(Voir contrib : http://www.spip-contrib.net/Texte-agrandi-ou-pleine-page)

J’ai suivit toutes les instructions de la page mais les boutons ne produisent aucun effet.
dans mon entete j’ai inséré le code suivant :
<script type="text/javascript">boutonstexte.selector = ".texte";</script>

et dans mon squelette j’ai insérer :

<img src="plugins/boutonstexte/images/fontsizeup.png" alt="fontsizeup" class="textsizeup" />
<img src="plugins/boutonstexte/images/fontsizedown.png" alt="fontsizedown" class="textsizedown" />

Les boutons apparaisent dans les pages du site mais n’agissent pas.

Ai-je oublié quelque chose ?


  • #1 > Problème plugin Boutons Texte ˆ
    par Fil - 10 septembre 2008 16:39

    Le texte que tu souhaites agrandir doit se trouver dans un div de class="texte".


  • < #2 > Problème plugin Boutons Texte ˆ
    par diego - 11 septembre 2008 12:12

    Merci, c’était ça.
    En fait il suffit juste d’installer le plugin dans SPIP puis rajouter des <div class="texte"> autour des zones de texte concernées.


  • < #3 > Problème plugin Boutons Texte ˆ
    par A. LE GALL - 11 janvier 2009 22:06

    Bonsoir,
    Je me trouve devant le même problème avec spip 2.2 et SarkaSpip 3. Concrètement, c’est quoi insérer div class="texte" : où et quand exactement ? Je ne comprends pas toutes les litotes des spipiens aguerris...
    Merci.


  • < #4 > Problème plugin Boutons Texte ˆ
    par SarkASmeL - 11 janvier 2009 22:19

    Salut A. Le Gall,

    Sous Sarka-SPIP3 surtout ne touche à rien. Tu vas dans la configuration du squelette Sarka-SPIP, page Plugins et là tu choisis l’option " Configurer le plugin avec les valeurs nécessaires à Sarka-SPIP ". Ensuite les boutons A- et A+ du bandeau fonctionneront sur la bonne partie du site.

    Voila...

    PS : mieux vaut déposer tes questions Sarka-SPIP sur notre forum


  • < #5 > Problème plugin Boutons Texte ˆ
    par Imagiris - 26 janvier 2010 17:18

    salut a tous.

    j’ai bien lu tout ou presque sur les" bouton texte" ;augmenter ou diminuer la police de caractère.

    je ne parviens toujours pas a le faire fonctionner.

    Activation avec cfg......nada.

    N’étant pas informaticien et ne connaissant pas le langage adéquat,il m’est difficile de comprendre ce qui ne fonctionne pas.

    installation de Spip 2+sarka3+cfg+couteau suisse....

    Merci de votre patience et de votre réponse.


  • < #6 > Problème plugin Boutons Texte ˆ
    par A. LE GALL - 26 janvier 2010 17:49

    Bonjour,

    La question m’échoit parce que je suis le dernier sur la liste, mais c’est le précédent, SarKasmel, qui m’avait éclairé.
    J’ai fait comme il le préconise : "Tu vas dans la configuration du squelette Sarka-SPIP, page Plugins et là tu choisis l’option " Configurer le plugin avec les valeurs nécessaires à Sarka-SPIP " - Je ne fais rien d’autre et cela a marché, une fois activé le plugin "Bouton Texte" dans Gestion des plugins.

    Bon courage.


  • < #7 > Problème plugin Boutons Texte ˆ
    par Imagiris - 26 janvier 2010 18:17

    Bonjour,

    suite,je viens de suivre la procédure de validation dans sarka spip ok ,validation du plugin bouton....
    ok puis dans boutons texte : boutonstexte:augmenterxxxpolice au lieu de :boutonstexte:augmenter_polce .

    retour dans spip et ecrire un nouvel article :

    je frappe le texte et après : a ce niveau pas de A_ ou A+

    quoi faire ,comment selectionner la partie de texte pour faire apparaitre les boutons pour augmenter la police. merci


  • < #8 > Problème plugin Boutons Texte ˆ
    27 janvier 2010 14:56

    Bonjour,

    et mille excuses pour la question du boutontexte que je retrouve sur la page du site et qui fonctionne.

    Mais je pensais que ces deux boutons seraient dans la page de l’écriture des articles, afin de faire des différences d’écriture directement dans l’article et non dans sa lecture.

    Question :quel est le plugin le plus approprié afin de modifierla police a partir de son écriture,comme dans cette page ou je ne voie pas de bouton A_ ou A+.

    Merci


  • < #9 > Problème plugin Boutons Texte ˆ
    par Fil - 27 janvier 2010 15:05

    Ce que tu cherches ressemble au plugin Édition plein écran.


  • < #10 > Problème plugin Boutons Texte ˆ
    27 janvier 2010 15:35

    Bonjour,

    je m’explique très mal,car ce que je désire c’est la possibilité d’écrire un texte dans lequel certains mots seraient d’une police différente et d’une hauteur différente ou d’une couleur différente.

    Merci


  • < #11 > Problème plugin Boutons Texte ˆ
    par RealET - 27 janvier 2010 18:58

    En fait, ce que tu veux faire, c’est donc sortir de la charte graphique d’un site en permettant de changer la taille de certaines partie du texte.

    Si tu veux vraiment faire cette horreur typographique, il y a une lame du Couteau Suisse qui peut permettre de faire ça (avec plus ou moins de configuration...).

    Ne me demande pas comment : je suis contre ;-)


  • < #12 > Problème plugin Boutons Texte ˆ
    28 janvier 2010 14:13

    Bonjour

    - ne vouloir s’en tenir qu’à ce qui est faisable,on finit par défendre ce qui se fait-

    Quel horreur ? comme je ne peux le faire dans l’immédiat l’irréparable n’est pas commis.

    Je trouve que la hauteur des caractères est trop petite pour une lecture facile (c’est probablement la vieillesse ou ..),
    je souhaite donc pouvoir écrire dans une police plus grande,(au lieu de 10 par exemple écrire en 12 OU 14 comme sous Word).

    Le reste c’est peut être hallucinant mais ..

    Salut a plus


  • < #13 > Problème plugin Boutons Texte ˆ
    par RealET - 28 janvier 2010 14:42

    C’est pas clair ta demande.

    1. tu veux que les caractères de l’ensemble du texte soient plus gros dans l’espace d’administration pour mieux lire ?
    2. ou tu veux changer ponctuellement la taille de quelques mots sur le site public ?
    3. ou tu veux permettre comme sur http://www.latabledaline.fr/ de grossir à la demande le texte des articles sur le site que vistent les internautes.

    Si c’est 1), alors, c’est les CSS de l’espace d’administration qu’il faut modifier.

    Si c’est 2), une lame du Couteau Suisse permet de faire ça.

    Si c’est 3), c’est le rôle du plugin Bouton Texte qui ne marche que du côté du site public.


  • < #14 > Problème plugin Boutons Texte ˆ
    par Imagiris - 28 janvier 2010 16:35

    boujour,

    oui c’est cela je veux pouvoir changer la hauteur de quelques mots sur le site public,comme le titre très gros,le soustitre un peut plus petit,le texte encore un peut plus petit et parfois grossir quelques mots dans le texte .

    Donc le couteau suisse !!!!! merci pour cette information.

    salut a plus


  • < #15 Problème plugin Boutons Texte ˆ
    par RealET - 28 janvier 2010 19:42

    Attention, pour titre et sous titre, c’est juste la feuille de style du site qu’il faut changer/adapter.

    Pour quelques mot dans le texte, c’est bien l’horreur typographique dont je parlais plus haut : sortir de la charte. Pour quelle raison vouloir sortir de la charte graphique/typographique du site ?

    Généralement, vouloir mettre un mot en plus gros, c’est la traduction inconsciente qu’il manque un titre pour manifester l’articulation du texte...


  •  


Répondre à la question

« Problème plugin Boutons Texte »

Mots-clés

Vous pouvez étiqueter cette page de forum avec les mots-clés qui vous semblent les plus appropriés ; ils permettront aux prochains visiteurs du site de mieux se repérer :


Installation, mise à jour

Utilisation de l’espace privé

Administration, gestion, configuration du site

Créer ses squelettes

Qui êtes-vous ?

  • Impossible d'éditer un auteur (site existant importé)

    par kikinovak
    25 juin 12:48

    Résolu - Réponse(s) : 3

    J’ai fini par trouver. En fait il s’agit d’un SPIP considérablement modifié, avec pas mal de plugins tiers, dont un qui posait problème. Ça venait d’un bug dans une version personnalisée du fichier (...)

  • Site inaccessible selon les browsers

    par abel
    23 juin 08:01

    Réponse(s) : 2

    Merci pour ta réponse :) Donc les navigateurs auraient une tolérance différentes selon le temps de chargement de la page ? Parce-que ceux qui ne chargent pas le site ne le font jamais, et sur (...)

  • Fonction "recherche d'adresse" de GIS cassée sur sites récents

    par b_b
    16 juin 11:44

    Résolu - Réponse(s) : 3

    Pour info, la version 4.43.6 de GIS devrait corriger ce problème, cf : https://zone.spip.org/trac/spip-zone/changeset/104884 ++

  • numérotation incohérente ?

    16 juin 09:49

    Résolu - Réponse(s) : 1

    Réponse trouvée si ça intéresse quelqu’un : la base de donnée Mysql du fournisseur d’accès numérote les enregistrements par pas de 3... Obligation donc de réécrire les squelettes en les compliquant un (...)

  • Site multilingue déféctueux

    par Didine
    16 juin 06:46

    Réponse(s) : 1

    Bonjour, Par défaut la page traduite créée est en français, il faut donc vérifier que ta page dans le secteur anglais a bien comme langue l’anglais. Sinon pour afficher la bonne page selon la langue (...)

  • Erreur système (errno 130)

    par erational
    5 juin 08:17

    Réponse(s) : 3

    Peut-on connaitre le nom de l’hébergeur ? Si tu as des bases en données en plus ? Si oui, tu peux essayer de cloner ta base et la brancher sur la nouvelle base ? Tiens nous au (...)

  • installation de themes

    30 mai 18:36

    Réponse(s) : 9

    La 1ere question du #6 est sans réponse. Celà pourrait aider à résoudre ton prob.

  • bug après avoir essayé de vider le cache

    par arcadiamo
    26 mai 18:34

    Réponse(s) : 4

    Merci , mais j’essayerai quand j’aurais résolu l’accès au serveur FTP car là je n’ai accès a rien du tout.

  • Une erreur technique a empêché l'enregistrement correct du champ 'date_lim'

    par laetitia
    24 mai 17:57

    Réponse(s) : 2

    en continuant mes recherches, je suis tombée sur un post intéressant dans lequel on parle de l’« affichage des calendriers des dates comme dans l’interface privée et à faire en sorte que le (...)

  • Probleme d'encodage en base de données

    par erational
    25 mai 12:30

    Réponse(s) : 2

    le plugin grenier peut parfois aider : https://contrib.spip.net/Convertir-un-site-SPIP-3-en-utf-8-avec-le-plugin

  • Messages : 29607
  • 8700 34 %
  • Poser une nouvelle question