[ar] [ca] [cpf] [de] [en] [es] [fr] [it]

Ce forum d’entraide est recommandé pour les utilisateurs et utilisatrices occasionnels de SPIP (Système de publication pour l’Internet). Avant de poser une question, faites une recherche sur ce site, consultez les liens utiles. Si vous ne trouvez pas de réponse, postez votre message dans la rubrique appropriée, avec un titre explicite.

Sujets : 24004 Sujets résolus :  39 %

32 visiteurs en ce moment


Problème de filtre sur #DATE

par Manda - 26 août 2005 14:48 - Réponse(s) : 13

Bonjour,
Je n’arrive plus à utiliser les expressions du type (#DATE|jour), (#DATE|mois),(#DATE|annee)... au lieu de m’afficher ma date, spip me renvoi des termes du type "date_jour_2".
Bref, quel fichier gère ces expressions ? (que je le remplace s’il a été modifié...)


  • #1 > Problème de filtre sur #DATE ˆ
    par mortimer - 26 août 2005 15:05

    Il y a pas mal de fichiers qui gérent ça : ecrire/inc_filtres.php3 inc-balises.php3 et les fichiers du compilos en lui même.

    On peut voir ta boucle pour infos ?


  • < #2 > Problème de filtre sur #DATE ˆ
    par Manda - 26 août 2005 15:17

    Un morceau de boucle incriminée :


    [

    <:derniers_commentaires :>

      ]
      /B_forums_decompte>


  • < #3 > Problème de filtre sur #DATE ˆ
    par Manda - 26 août 2005 15:20

    Désolée pour la mise en forme... De quelle manière je peux afficher le code proprement ?


  • < #4 > Problème de filtre sur #DATE ˆ
    par mortimer - 26 août 2005 15:29

    il faut utiliser &ltcode>


  • < #5 > Problème de filtre sur #DATE ˆ
    par mortimer - 26 août 2005 15:30

    grr, c’est la balise <code>


  • < #6 > Problème de filtre sur #DATE ˆ
    par Manda - 26 août 2005 15:42

    ok, a titre d’exemple donc un morceau de code, qui m’affiche à la place de ma date des lignes du genre "date_fmt_jour_mois" :

    <BOUCLE_forums_decompte(FORUMS){id_article}{plat}></BOUCLE_forums_decompte>
    [<div class="boite">
            <h3><:derniers_commentaires:></h3>
                    <ul class="forums">
                            <li class="menu-titre"><:messages_forum:>: (#TOTAL_BOUCLE)</li>]
    <//B_forums_decompte>
            <BOUCLE_forums_liens(FORUMS){id_article}{par date}{inverse}{0,5}>
                               <li class="menu-item">[<i>(#DATE|affdate_court)</i>:]
                                       <a href="#forum#ID_FORUM">#TITRE</a>
                               </li>
            </BOUCLE_forums_liens>
                    </ul>
    </div>
            </B_forums_liens>

    Je débute dans Spip, donc je ne vois pas trop de quoi ca peut venir. Les fonctions avec les filtre ne posent pas de problèmes dans des boucles simples (genre 1 boucle + appel de la date), mais ne marchent plus quand le code se complexifie...


  • < #7 > Problème de filtre sur #DATE ˆ
    par Fil - 26 août 2005 16:00

    Je dirais qu’il manque les fichiers de langue (ou que ceux-ci, s’ils sont présents, sont devenus illisibles [vérifier les permissions] ou garblés [vérifier le contenu]).


  • < #8 > Problème de filtre sur #DATE ˆ
    par mortimer - 26 août 2005 16:06

    les fichiers de langues se trouvent dans le répertoire ecrire/lang pour info


  • < #9 > Problème de filtre sur #DATE ˆ
    par Manda - 26 août 2005 16:41

    Tout a l’air correct au niveau du contenu... qu’entends tu par permissions ?


  • < #10 > Problème de filtre sur #DATE ˆ
    par Fil - 26 août 2005 18:14

    permissions : il faut que ces fichiers soient lisibles par le serveur web

    mais le problème vient peut-être d’ailleurs ; peux-tu vérifier que le fichier ecrire/inc_lang.php3 a bien été uploadé ?


  • < #11 > Problème de filtre sur #DATE ˆ
    par Manda - 29 août 2005 09:30

    Oui, inc-lang est bien là...
    Bon, je vais continuer à bidouiller en attendant... Le problème viendrait donc bien d’un fichier corrompu alors ? Il faudrait peut être que je re-upload spip ou certain de ses dossiers ?


  • < #12 > Problème de filtre sur #DATE ˆ
    par Manda - 29 août 2005 09:42

    Bon, je crois avoir trouvé...
    Pour permettre de remplacer l’affichage de "date de publication anterieure" dans l’interface d’admin par "date de l’évenement", j’ai rajouté un fichier local_fr avec ça dedans :

    <?php
       $GLOBALS['i18n_spip_fr']['texte_date_publication_anterieure'] = 'DATE DE L\'EVENEMENT';
       $GLOBALS['i18n_spip_fr']['texte_date_publication_anterieure_nonaffichee'] = 'L\'article n\'a pas de date d\'&eacute;v&eacute;nement.';
    ?>

    (bon, je l’ai pas inventé toute seule, je vous rassure ^^)

    Bref, je l’ai supprimé, et ça remarche :)

    Si quelqu’un pouvait m’expliquer le pourquoi du comment, je serais preneuse !


  • < #13 Problème de filtre sur #DATE ˆ
    par Fil - 29 août 2005 12:25

    Pour info, le format des fichiers de langue a (un peu) changé ; regarde dans ecrire/lang/spip_fr.php3 pour voir la nouvelle syntaxe.




Répondre à la question

« Problème de filtre sur #DATE »

Mots-clés

Vous pouvez étiqueter cette page de forum avec les mots-clés qui vous semblent les plus appropriés ; ils permettront aux prochains visiteurs du site de mieux se repérer :


Installation, mise à jour

Utilisation de l’espace privé

Administration, gestion, configuration du site

Créer ses squelettes

Qui êtes-vous ?

  • Dates articles dans plan du site

    par Fa_b
    24 avril 22:36

    Réponse(s) : 6

    Bonjour, Il ne faut JA-MAIS modifier un fichier directement dans le dossier plugin, sinon à la prochaine maj du dit plugin, cela enlève vos modifs. Pour éviter cela spip utilise le mécanisme de (...)

  • Impossible d'importer ma base dans une install en localhost

    par Ajel
    23 avril 10:59

    Résolu - Réponse(s) : 18

    Merci Fa_b, C’est exactement ça ; Problème résolu. Bonne journée.

  • Site SPIP, quelle solution e-commerce ?

    par Fa_b
    21 avril 11:06

    Réponse(s) : 22

    Je n’ai pas utilisé le plugin livraison car j’ai un calcul de frais de port plus simple (une simple multiplication par produit), je passe par le plugin Coordonnées pour avoir une adresse de livraison (...)

  • Peut-on surcharger un fichier d'un plugin ?

    par SB
    20 avril 15:17

    Résolu - Réponse(s) : 2

    Bonjour, Merci pour votre réponse rapide et efficace. Je viens de tester et ... ça fonctionne ! Pour arriver à cela, j’ai surchargé les fichiers : /jwplayer/player/jwplayer.js que j’ai enregistré (...)

  • utf-8 base de donnée externe Mysql

    par Afronob
    20 avril 10:24

    Résolu - Réponse(s) : 4

    Dès la version 2.1.30 en fait. Attention avec SPIP 3.1 il faut modifier un peu cette recette, cf. https://core.spip.net/issues/3506

  • Impossible d'enresgistrer le nom du site

    par Uriel
    18 avril 15:08

    Résolu - Réponse(s) : 7

    Résolu pour ce problème, oui, merci pour votre article. J’ai en effet pu installer la version 3.0.25 (mais le .htaccess ne marchais pas, je l’ai pris sur un autre site). Bonne (...)

  • SPIP sous OVH et gestion avancée des URL ?

    par vr34
    10 avril 12:09

    Résolu - Réponse(s) : 4

    lol : maintenant ça fonctionne ! avec le htaccess de ton lien, c’est nickel :-) pourtant ils font tous les deux 5243 octets !!! je vais les comparer un grand merci (...)

  • Site en travaux Attention : un problème technique (serveur SQL) empêche l'accès à cette partie du site. Merci de (...)

    9 avril 16:41

    Résolu - Réponse(s) : 5

    Merci pour votre réponse, Après des essais ; en désactivant les dossiers squelettes, plugins, vider le cache et même réinstaller spip. J’ai contacté le support de Hostpapa et il s’avers que le blocage (...)

  • Contenu colonne droite décalé vers le bas

    par Chrys
    7 avril 10:54

    Réponse(s) : 5

    C’est une supposition vu ce que tu décris, idéalement comme dit en #1 avec un lien sur la page concernée serai plus simple…

  • Modifier Modène vidéo

    par Chrys
    6 avril 20:02

    Résolu - Réponse(s) : 4

    Pas de soucis. Pour une fois que je peux a mon modeste niveau faire qq chose ! Ce forum m’a plus souvent aidé ;-) A de prochaine aventures

  • Messages : 29505
  • 8676 34 %
  • Poser une nouvelle question