[ar] [ca] [cpf] [de] [en] [es] [fr] [it]

Sujets : 35 Sujets résolus :  50 %

54 besucheranzahl heute


Startseite > Diskussionsforen >  Das Redaktionssystem > SPIP mit PHP 5.4? Programmierer gesucht!

SPIP mit PHP 5.4? Programmierer gesucht! Résolu

von vt2021 - 8. Januar 2013 20:35 - Antworten : 2

Hallo liebe SPIP-Profis,

wir betreiben eine Website mit SPIP v. 1-7-1.
Ist es möglich, diese in eine PHP 5.4-kompatible Form zu bringen?

Falls ja suche ich für dieses Projekt jemanden, der mich unterstützen kann und das Update bzw. die nötige Programmierung übernimmt. Kontaktiert mich dazu gerne unter spip@identivis.de.

Vielen Dank!
- vt2021

SPIP 1-7-1


  • #1 > SPIP mit PHP 5.4? Programmierer gesucht! ˆ
    von klaus++ - 9. Januar 2013 00:33

    Ha! Eine Herausforderung! SPIP 1.7 -> SPIP 3 stellt einen Sprung über 2 Haupt-Versionen und einige wichtige Zwischenversionen dar.

    Falls die Website keine selbstprogrammierten Erweiterungen enthält, sollte kein Problem beim Update auftreten.

    Trotzdem empfiehlt es sich, die Website vor solch einem Versionssprung komplett zu sichern (Datenbank nicht nur mit SPIP sichern, sondern einen richtigen MySQL-Dump machen). Ich würde außerdem eine lokale Kopie der 1.7-Website installieren und das Update mit ihr ausprobieren.

    Zunächst würde ich ein Update auf SPIP 2 machen, die Website testen und dann, wenn alles geklappt hat, auf SPIP 3 updaten.

    Selbstprogrammierte Erweiterungen bedürfen besonders dann einer Überarbeitung, wenn sie als PHP-Code in Skelette eingebaut wurden, denn mit SPIP3 erfolgten ein paar wesentliche Änderungen am Cache-Mechanismus von SPIP, so daß gelegentlich Programmcode nach einem Update einfach nicht mehr ausgeführt wird. Selbstverständlich muß man seinen PHP-Code auch auf Funktionen prüfen, die, ganz unabhängig von SPIP, von neueren PHP-Versionen nicht mehr unterstütz werden.

    Details zu den Updates finden sich auf spip.net.


  • Hallo klaus ++,

    vielen Dank für die schnelle ausführliche Antwort!! :-). Das lässt mich hoffen! Tatsächlich glaube ich, das es bei uns zwei manuelle Anpassungen gibt.

    Klaus, würdest Du einen Auftrag zur Umstellung einer Website annehmen?

    Ich traue mir das selbst nicht zu und suche eher nach einem Profi der es in die Hand nimmt als nach einer Lösung zum selbermachen. :-)

    Viele Grüße!
    - vt2012
    spip@identivis.de


  •  


Auf diese Frage antworten

« SPIP mit PHP 5.4? Programmierer gesucht! »

Schlagworte

Sie können diese Seite nach Belieben verschlagworten. Damit helfen Sie den nächsten Lesern bei der Orientierung.


1. Installation, mise à jour

2. Utilisation de l’espace privé

3. Administration, gestion, configuration du site

4. Créer ses squelettes

Wer sind Sie?

  • SPIP mit PHP 5.4? Programmierer gesucht!

    11. Januar 2013 17:53

    Erledigt - Antworten : 2

    Hallo klaus ++, vielen Dank für die schnelle ausführliche Antwort!! :-). Das lässt mich hoffen! Tatsächlich glaube ich, das es bei uns zwei manuelle Anpassungen gibt. Klaus, würdest Du einen (...)

  • Bild oder Dokumenten upload: Bild wird nicht erkannt

    von klaus++
    10. Januar 2013 14:52

    Erledigt - Antworten : 4

    SPIP 3 verhält sich so: Bilder im Portfolio werden als Sammlung (Portfolio eben) verkleinerter Bilder unter dem Artikel angezeigt. Werden sie in dn Artikel eingebunden, verschwinden sie aus (...)

  • Dokumente downloaden

    von klaus++
    29. Dezember 2009 12:30

    Erledigt - Antworten : 1

    Ja. Dokumente können an Artikel angehängt oder in Rubriken angeboten werden. Der Administrator der Website kann das für seine Redakteure an- und abschalten.

  • Problem Logo-Schaltflöche

    von klaus++
    26. Juli 2005 22:04

    Antworten : 1

    Hallo Detlef, anscheinend sind Dateien auf Deinem Server beschädigt. Am besten machst Du ein Backup Deiner Website (Datenbank, Verzeichnis /IMG sowie alle Deine "Skelette" und selbst (...)

  • Nachrichten : 12
  • 4 100 %
  • Neue Frage stellen