[ar] [ca] [cpf] [de] [en] [es] [fr] [it]

Sujets : 35 Sujets résolus :  50 %

72 besucheranzahl heute


Zend PHP und IBM DB2

von GertDorn - 9. Dezember 2007 11:27 - Antworten : 3

Hallo liebe SPIP Profis.

nachdem ich versuche eine Seite mehrsprachig zu entwickeln, und hauptsächlich an Sonderzeichen für Französich und Italienisch gescheitert bin, habe ich SPIP gefunden .

Ich arbeite mit Zend PHP und IBM DB2 als Datenbank.
Leider scheitere ich schon bei der Installation weil MySQL verlangt wird.
Kann ich das Produkt auch für Oracle oder andere DB’S verwenden ?

Vilen Dank für ne Antwort.

gert


  • #1 > Zend PHP und IBM DB2 ˆ
    von klaus++ - 9. Dezember 2007 14:05

    Hallo Gert,

    SPIP 1.92 setzt noch MySQL voraus. SPIP 1.93 ist um ein Layer zur Datenbankabstraktion erweitert. Zur Zeit (Dezember 2007) werden damit MySQL und PostgreSQL unterstützt.

    Weitere Datenbankkonnektoren lassen sich hinzufügen. Die SPIP-Entwickler unterstützen Dich gerne bei der Programmierung eines Konnektors für DB2.


  • < #2 > Zend PHP und IBM DB2 ˆ
    9. Dezember 2007 18:59

    Hallo Klaus,

    danke für deine Nachricht.
    Folgende Frage.
    Wieso brauche ich eine DB ich denke die Texte (übersetzungen )
    liegen in Files.
    und was meinst Du mit einem CONNECTOR.
    du kannst jederzeit DB2 von PHP aus connecten auch ohne ZEND.

    Vielleicht verstehe ich nicht wie SPIP arbeitet.

    gruss gert


  • < #3 Zend PHP und IBM DB2 ˆ
    von klaus++ - 10. Dezember 2007 15:10

    Jede SQL-Datenbank spricht mehr oder weniger ihren eigenen Dialekt. SPIP bis Version 1.92 spricht den Dialekt von MySQL. Ab SPIP-Version 1.93 wird die Datenbank nicht mehr direkt per SQL-Befehl angesprochen, sondern eine Zwischenebene (database abstraction layer), die sich um die Übersetzung des Befehls in den SQL-Dialekt der verwendeten Datenbank kümmert. Es genügt dann, einen Treiber oder Konnektor für die gewünschte Datenbank zu schreiben, um sie mit dem Programm - in unserem Fall SPIP - zu nutzen. Es sind keine Änderungen am Programm selber erforderlich.

    Über die Spezifikation der Abstraktonsschicht und Treiber können die Entwickler von SPIP Auskunft geben. Wenn Du einen Treiber schreiben möchtest und nicht nicht auf Französisch danach fragen möchtest, kannst Du die englischsprachige Mailingliste spip-en@rezo.net nutzen oder ich frage für Dich in der Entwicklerliste.

    Warum muss es eigentlich DB2 sein? SPIP funktioniert sehr gut mit MySQL, das auf so gut wie alen Plattformen läuft?




Auf diese Frage antworten

« Zend PHP und IBM DB2 »

Schlagworte

Sie können diese Seite nach Belieben verschlagworten. Damit helfen Sie den nächsten Lesern bei der Orientierung.


1. Installation, mise à jour

2. Utilisation de l’espace privé

3. Administration, gestion, configuration du site

4. Créer ses squelettes

Wer sind Sie?

  • Nach Upgrade

    von klaus++
    28. Februar 2009 07:54

    Antworten : 5

    Klicke auf den Link.

  • Titel der Website

    von Matthias Burisch
    12. Februar 2009 14:08

    Antworten : 6

    Und nochmal: Gibt es jemanden im Raum Hamburg, der sich mit SPIP auskennt und — natürlich gegen Gage — eine Website betreuen würde? Bitte melden (040-42838-5470)! Matthias (...)

  • Zend PHP und IBM DB2

    von klaus++
    10. Dezember 2007 15:10

    Antworten : 3

    Jede SQL-Datenbank spricht mehr oder weniger ihren eigenen Dialekt. SPIP bis Version 1.92 spricht den Dialekt von MySQL. Ab SPIP-Version 1.93 wird die Datenbank nicht mehr direkt per SQL-Befehl (...)

  • Installation und Updates

    von Dirk
    12. Juli 2006 00:21

    Antworten : 2

    Wie kann ich ein sauberes Update durchfuehren!? Gruss Dirk

  • Neu Installation

    von klaus++
    5. März 2007 13:27

    Antworten : 1

    Hallo, wen Du Dein Passwort vergessen hast, schickt Dir SPIP ein neues zu. Auf dem Anmeldebildschirm klickst Du auf den Link "Passwort vergessen?" Viel Erfolg! (...)

  • > Installationsfehlermeldung

    von John Winter
    28. Dezember 2005 01:23

    Antworten : 7

    Hello World! Versucht mal folgendes in eurer .htaccess: "AddType application/x-httpd-php4 .php3" Das funzt bei Dienstleistern wie Strato, 1&1, usw... Viel (...)

  • Nachrichten : 30
  • 6
  • Neue Frage stellen